aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2020-03-30 07:24:12 +0000
committerAriadne Conill <ariadne@dereferenced.org>2020-03-30 07:24:39 +0000
commit0cb265d00803c757c72bb1d0d6151da148e53138 (patch)
tree0520444ca3a5a109541c8a4c6147a53f884963a1 /main/gcc
parent683e6154ddbeef9b4251a20999aa0835ea53b65f (diff)
downloadaports-0cb265d00803c757c72bb1d0d6151da148e53138.tar.bz2
aports-0cb265d00803c757c72bb1d0d6151da148e53138.tar.xz
main/gcc: enable D on mips, unconditionally install libucontext-dev
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD7
1 files changed, 1 insertions, 6 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 2de9724b47..4be10f27bf 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -93,11 +93,6 @@ fi
# See libphobos/configure.tgt in GCC sources for supported targets
[ "$CARCH" = ppc64le ] && LANG_D=false
-# GDC requires libucontext on mips, which is not yet available
-case "$CTARGET_ARCH" in
-mips*) LANG_D=false ;;
-esac
-
# Go needs {set,make,swap}context, unimplemented in musl
[ "$CTARGET_LIBC" = musl ] && LANG_GO=false
@@ -132,7 +127,7 @@ fi
if $LANG_D; then
subpackages="$subpackages libgphobos::$CTARGET_ARCH gcc-gdc$_target:gdc"
_languages="$_languages,d"
- [ "$CTARGET_ARCH" == "s390x" ] && makedepends_build="$makedepends_build libucontext-dev"
+ makedepends_build="$makedepends_build libucontext-dev"
fi
if $LANG_OBJC; then
subpackages="$subpackages libobjc::$CTARGET_ARCH gcc-objc$_target:objc"