aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorNils Andreas Svee <me@lochnair.net>2017-12-10 01:18:08 +0100
committerTimo Teräs <timo.teras@iki.fi>2017-12-11 09:00:06 +0200
commit2baf4807188617d1957dcbcadc1d60e6a6465af2 (patch)
treef514ad4ecf3681ea7e7e57c42238fcfe4adad58a /main/gcc
parentd73ebbab01b1a2afe88f1e4d98215d1080c0d913 (diff)
downloadaports-2baf4807188617d1957dcbcadc1d60e6a6465af2.tar.bz2
aports-2baf4807188617d1957dcbcadc1d60e6a6465af2.tar.xz
main/gcc: import patch from upstream fixing compilation issue on mips
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD4
-rw-r--r--main/gcc/fix-linux-header-use-in-libgcc.patch44
2 files changed, 47 insertions, 1 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 884feeb170..ea3b5b6a7d 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -185,6 +185,7 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${_pkgbase:-$pkgver}/gcc-${_pkgba
320-libffi-gnulinux.patch
fix-rs6000-pie.patch
+ fix-linux-header-use-in-libgcc.patch
"
# we build out-of-tree
@@ -625,4 +626,5 @@ fa44c8158111627aa0e91c43e7cc3aa38642c2041c96532dd4f0932dae4d6f92ea2850b683abcf10
4b4a0ff306a8ef34ff6e3284fbfca869012164a47ba7cb099085c1dd03e6ca0cdd462f82710e08c9a02895adc7484e4c5eef17b5aa264cf5d978fe8ad78eea93 300-main-gcc-add-musl-s390x-dynamic-linker.patch
385bc2fa50204f678964e5148c6170f572701dab920fbec8301f505bda34d182cde0adb7da042fee71719e12fb59f59181897f9b1bb4f4716ff59aad46ca1998 310-build-gcj-s390x.patch
f4ef08454e28c8732db69115e4998ec153399e8d229dd27f923dbdcf57b68128a65640d026cc7f45b58ba8764ab1eb575d4eb6d6dfc550a87a183f8b94e76181 320-libffi-gnulinux.patch
-01c71cd5881fc07ea3b9b980697e89b3ca0fe98502958ceafc3fca18b2604c844e2f457feab711baf8e03f00a5383b0e38aac7eb954034e306f43d4a37f165ed fix-rs6000-pie.patch"
+01c71cd5881fc07ea3b9b980697e89b3ca0fe98502958ceafc3fca18b2604c844e2f457feab711baf8e03f00a5383b0e38aac7eb954034e306f43d4a37f165ed fix-rs6000-pie.patch
+34a818d5be67eb1f34e44a80b83c28a9b9c17d37fc9fac639f490d6bb5b53ebe3318140d09c236a17d7c98f5a7792ae3d6cefccda8067a5e942d6305b9d1f87c fix-linux-header-use-in-libgcc.patch"
diff --git a/main/gcc/fix-linux-header-use-in-libgcc.patch b/main/gcc/fix-linux-header-use-in-libgcc.patch
new file mode 100644
index 0000000000..6dad1b2cad
--- /dev/null
+++ b/main/gcc/fix-linux-header-use-in-libgcc.patch
@@ -0,0 +1,44 @@
+From 9cd4503714c4e596818c4ea8e15905c249b7a319 Mon Sep 17 00:00:00 2001
+From: nsz <nsz@138bc75d-0d04-0410-961f-82ee72b054a4>
+Date: Thu, 25 Aug 2016 14:08:27 +0000
+Subject: [PATCH] [mips] Fix linux header use in libgcc
+
+libgcc/
+ * config/mips/linux-unwind.h: Use sys/syscall.h.
+
+
+
+git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@239759 138bc75d-0d04-0410-961f-82ee72b054a4
+---
+ libgcc/ChangeLog | 4 ++++
+ libgcc/config/mips/linux-unwind.h | 2 +-
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/libgcc/ChangeLog b/libgcc/ChangeLog
+index b78c4b2..99bd2f1 100644
+--- a/libgcc/ChangeLog
++++ b/libgcc/ChangeLog
+@@ -1,3 +1,7 @@
++2016-08-25 Szabolcs Nagy <szabolcs.nagy@arm.com>
++
++ * config/mips/linux-unwind.h: Use sys/syscall.h.
++
+ 2016-08-16 Joseph Myers <joseph@codesourcery.com>
+
+ PR libgcc/77265
+diff --git a/libgcc/config/mips/linux-unwind.h b/libgcc/config/mips/linux-unwind.h
+index bf12de5..4035c121 100644
+--- a/libgcc/config/mips/linux-unwind.h
++++ b/libgcc/config/mips/linux-unwind.h
+@@ -27,7 +27,7 @@ see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
+ state data appropriately. See unwind-dw2.c for the structs. */
+
+ #include <signal.h>
+-#include <asm/unistd.h>
++#include <sys/syscall.h>
+
+ /* The third parameter to the signal handler points to something with
+ * this structure defined in asm/ucontext.h, but the name clashes with
+--
+2.9.3
+