aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-07-13 06:46:17 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-07-13 06:52:14 +0000
commit5e4b96e23871ee28ef593b439f8c07ca7c7eb5bb (patch)
treeb1d10452e1f57da3f1d60f4b707a003fa9d3d66e /main/gcc
parentd7ce4462f7a826e483be426d96537d52b6e2cc20 (diff)
downloadaports-5e4b96e23871ee28ef593b439f8c07ca7c7eb5bb.tar.bz2
aports-5e4b96e23871ee28ef593b439f8c07ca7c7eb5bb.tar.xz
main/gcc: update to 6.4.0
- remove patches merged upstream - remove aarch64 workaround needed for PR77455 that is now fixed
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/202-posix_memalign.patch42
-rw-r--r--main/gcc/APKBUILD25
-rw-r--r--main/gcc/ada-aarch64-multiarch.patch16
-rw-r--r--main/gcc/libada-cross-shared.patch22
4 files changed, 22 insertions, 83 deletions
diff --git a/main/gcc/202-posix_memalign.patch b/main/gcc/202-posix_memalign.patch
deleted file mode 100644
index 2018575088..0000000000
--- a/main/gcc/202-posix_memalign.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From bab47fac06af5d891caaccac99f1dc1e75bdc219 Mon Sep 17 00:00:00 2001
-From: Szabolcs Nagy <nsz@port70.net>
-Date: Sat, 1 Aug 2015 23:24:07 +0000
-Subject: [PATCH 2/6] posix_memalign
-
----
- gcc/config/i386/pmm_malloc.h | 9 +++++----
- 1 file changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/gcc/config/i386/pmm_malloc.h b/gcc/config/i386/pmm_malloc.h
-index a1f98d3..4f6b2dc 100644
---- a/gcc/config/i386/pmm_malloc.h
-+++ b/gcc/config/i386/pmm_malloc.h
-@@ -27,12 +27,13 @@
- #include <stdlib.h>
-
- /* We can't depend on <stdlib.h> since the prototype of posix_memalign
-- may not be visible. */
-+ may not be visible and we can't pollute the namespace either. */
- #ifndef __cplusplus
--extern int posix_memalign (void **, size_t, size_t);
-+extern int _mm_posix_memalign (void **, size_t, size_t)
- #else
--extern "C" int posix_memalign (void **, size_t, size_t) throw ();
-+extern "C" int _mm_posix_memalign (void **, size_t, size_t) throw ()
- #endif
-+__asm__("posix_memalign");
-
- static __inline void *
- _mm_malloc (size_t size, size_t alignment)
-@@ -42,7 +43,7 @@ _mm_malloc (size_t size, size_t alignment)
- return malloc (size);
- if (alignment == 2 || (sizeof (void *) == 8 && alignment == 4))
- alignment = sizeof (void *);
-- if (posix_memalign (&ptr, alignment, size) == 0)
-+ if (_mm_posix_memalign (&ptr, alignment, size) == 0)
- return ptr;
- else
- return NULL;
---
-2.8.1
-
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index e7ce880603..7bea5d0f2e 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -1,7 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gcc
-pkgver=6.3.0
-_pkgbase=6.3.0
+pkgver=6.4.0
[ "$BOOTSTRAP" = "nolibc" ] && pkgname="gcc-pass2"
[ "$CBUILD" != "$CHOST" ] && _cross="-$CARCH" || _cross=""
[ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
@@ -32,14 +31,6 @@ LIBGCC=true
LIBATOMIC=true
LIBITM=true
-# omit-frame-pointner will break libgcc on aarch64
-# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71951
-if [ "$CARCH" = aarch64 ]; then
- export CFLAGS=${CFLAGS//-fomit-frame-pointer/}
- export CXXFLAGS=${CXXFLAGS//-fomit-frame-pointer/}
- export CPPFLAGS=${CPPFLAGS//-fomit-frame-pointer/}
-fi
-
if [ "$CHOST" != "$CTARGET" ]; then
if [ "$BOOTSTRAP" = nolibc ]; then
LANG_CXX=false
@@ -151,7 +142,7 @@ if $LANG_ADA; then
fi
makedepends="$makedepends_build $makedepends_host"
-source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${_pkgbase:-$pkgver}/gcc-${_pkgbase:-$pkgver}.tar.bz2
+source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${_pkgbase:-$pkgver}/gcc-${_pkgbase:-$pkgver}.tar.xz
ftp://sourceware.org/pub/java/ecj-4.9.jar
001_all_default-ssp-strong.patch
@@ -168,14 +159,12 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${_pkgbase:-$pkgver}/gcc-${_pkgba
090_all_pr55930-dependency-tracking.patch
201-cilkrts.patch
- 202-posix_memalign.patch
203-libgcc_s.patch
204-linux_libc_has_function.patch
205-nopie.patch
207-static-pie.patch
libgcc-always-build-gcceh.a.patch
- libada-cross-shared.patch
gcc-4.9-musl-fortify.patch
gcc-6.1-musl-libssp.patch
boehm-gc-musl.patch
@@ -189,6 +178,7 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${_pkgbase:-$pkgver}/gcc-${_pkgba
ada-fixes.patch
ada-shared.patch
ada-musl.patch
+ ada-aarch64-multiarch.patch
300-main-gcc-add-musl-s390x-dynamic-linker.patch
310-build-gcj-s390x.patch
@@ -238,10 +228,8 @@ build() {
cd "$_gccdir"
- # temp disable boostrap for aarch64 see bug:
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71989
case "$CTARGET" in
- aarch64-*-*-*) _arch_configure="--with-arch=armv8-a --with-abi=lp64 --disable-bootstrap";;
+ aarch64-*-*-*) _arch_configure="--with-arch=armv8-a --with-abi=lp64";;
armv5-*-*-*eabi) _arch_configure="--with-arch=armv5te --with-tune=arm926ej-s --with-float=soft --with-abi=aapcs-linux";;
armv6-*-*-*eabihf) _arch_configure="--with-arch=armv6zk --with-tune=arm1176jzf-s --with-fpu=vfp --with-float=hard --with-abi=aapcs-linux";;
armv7-*-*-*eabihf) _arch_configure="--with-arch=armv7-a --with-tune=generic-armv7-a --with-fpu=vfpv3-d16 --with-float=hard --with-abi=aapcs-linux --with-mode=thumb";;
@@ -600,7 +588,7 @@ gnat() {
mv "$pkgdir"/usr/bin/*gnat* "$subpkgdir"/usr/bin/
}
-sha512sums="234dd9b1bdc9a9c6e352216a7ef4ccadc6c07f156006a59759c5e0e6a69f0abcdc14630eff11e3826dd6ba5933a8faa43043f3d1d62df6bd5ab1e82862f9bf78 gcc-6.3.0.tar.bz2
+sha512sums="02c60e54527c7adf584798d5251f8a0b80c93d5deafce82501b2c28e6692e0bd783927bbfc4bc527a863c0cccc025150a34740a9e29badb02d4b48e56a8aba90 gcc-6.4.0.tar.xz
28f8c6fdbcb19e950b1d0bafb3bcc7a8cba87bc673aa6027cece116599cdee80f0cf5e95a1440544890239f5c754e8a93ab46d9daedd937faef445d7ea33b226 ecj-4.9.jar
a1335adc2fbee98e36c4437ff2587771b98ed4180726779020f65039498235626a411cdb0100dbd20cd19d12f0d94f9a21af179ff624676c28cead9d60598b5d 001_all_default-ssp-strong.patch
e36e95b81489163abd6fe9d58f7867bdca43e61143afacbfb17f4698c0b16ec5fd0061d8fab7b2ae615540bebd721c2e2227f80401b4e7fc253da9da62e6b513 002_all_default-relro.patch
@@ -615,13 +603,11 @@ e7a2eb1b1870e199d6fd753d065781575656fa12baa264f96c5d179689d88c31b8a3f92a5dae9608
e87da18aa7ab92b02b06168658c63b42a6c73a08fad2a30f81ef6296100fdbe3c3a91548fd0cb24eaf591e862bb08e4b67249bc4b977b07da33523aee0c686bc 067_all_gcc-poison-system-directories.patch
4a328d1e1a56c20166307edcfa322068915784d9c08025b7f81cf69714da48fc266b6d34f77b9135c2f10da830d9df408276a1b78d1fd218637c2823506593c2 090_all_pr55930-dependency-tracking.patch
ef052d0c3c9642fcb5ed570069c5a49c8ef523c47ac8ce3f201a801766f72ae4ff7c3725a70ee66e52c0fb559621e35fe0cf5b88b901d71ceadd381f49653a08 201-cilkrts.patch
-40b7f2fc44fbe8125027c424f9ef3e6b89129ee4c6d47f3f3075f28979bcece2a3bc0ddd17df6bae77960db773f48fba2eb252923063ac81788340e7ec575d99 202-posix_memalign.patch
808e206f5e107084156fba333d4e091dcbd62f5d7756142bc292d4b0a52619f8c2aaca3617defc2f5b6552ba0439aebd33f4141329d88eab6ddf2dd637d92c08 203-libgcc_s.patch
fc0de05b36613b732a0222ea005c90653c6a40d6761b6894af2419272f4e74875f37e26af33a9b9940669ef89269c44c46d17ca5bcd54b5cd1176e5eaf2992c1 204-linux_libc_has_function.patch
98473bcaa77903a223ca9b0d2087c0921b287a2816d308cc32c8fe009e6cbf5dd1ae7fba27794ab8d9c09e117fe534413d91a464d1218474fc123ce0adfdc2c1 205-nopie.patch
3287d5b443bea8ec64132bcabe869c738ae98ea8f1a86df1c5d18c927f8816edbfcefeefc47792dbbb2bcacf50319af00e01b3735d34525913b64350770ad453 207-static-pie.patch
d08d7ead2de0429e5c9055d5b029ec2be9a8c821d22cecaf9b51f633652c493333f98963d9267fa2fa63850c50ae5eefd5f59e5910ec10d20044dac082182a8b libgcc-always-build-gcceh.a.patch
-497e73650b4e7ac1cc92158b993f543b1506d3af4f9df9cb1e9504af4db657a9fc6e4429b4cb2bf5b3c1c8c06a5cec5d8b19bc958fd57b92d7b4d5e58b34554c libada-cross-shared.patch
600fe5098dc54edaa9808fd5717af9dec058953f9ad37d49cfba1db4f7e9a7a8f02019342f75157fc575946fa693259422184de27b7ecc8386d9f3ecc0f7cc5d gcc-4.9-musl-fortify.patch
dbe0ee917fc7668571722364ab7c806731e3a31e8bfa30b4941b28b16b877d2a32b4a3897ef533399a28f82d43cac9b28e92de0493f0e779046db56584e07fa4 gcc-6.1-musl-libssp.patch
bda845a6aa1854d2c883910b115f79ccfa93dfc2b5eac69a3a236d83eb34cadc140731d616ffc24698c7abc8878dd15f231bcc5119f1860e575a120b311706c7 boehm-gc-musl.patch
@@ -634,6 +620,7 @@ abe9aaf9aa956058d0386a4396a511d176a46bb3906b90e952383646cdc158cbeb0a5dc616a1ccb1
9016b257abd8fa981de44a49512e35db814d1cbb47c1a87cd31c12d4ae20b13e9e149fe41691a7ec3c95bbcfde8a79194a8d2eaf547ceade3a246fad67c47dd8 ada-fixes.patch
3f5bc334d9f73d06f5f7c876738d02356acdd08958bea0e4d2095ebf15c2c2ec4e411abdae0297505ae9a1699ca01b17338e853184e84663203b192b0d35fc19 ada-shared.patch
631d4bdef6d8bde34df7978bb53ec28c3c909cf1f87139e5f148138d0f09adc58b41ecf0148bbf50fb4bc916c411e9bf8a2b6c046c75c0e77d754d8c35bcd4d7 ada-musl.patch
+fa44c8158111627aa0e91c43e7cc3aa38642c2041c96532dd4f0932dae4d6f92ea2850b683abcf10e7e120299d42ea6b69adc00002a514c76be8e39e99fa052b ada-aarch64-multiarch.patch
4b4a0ff306a8ef34ff6e3284fbfca869012164a47ba7cb099085c1dd03e6ca0cdd462f82710e08c9a02895adc7484e4c5eef17b5aa264cf5d978fe8ad78eea93 300-main-gcc-add-musl-s390x-dynamic-linker.patch
385bc2fa50204f678964e5148c6170f572701dab920fbec8301f505bda34d182cde0adb7da042fee71719e12fb59f59181897f9b1bb4f4716ff59aad46ca1998 310-build-gcj-s390x.patch
f4ef08454e28c8732db69115e4998ec153399e8d229dd27f923dbdcf57b68128a65640d026cc7f45b58ba8764ab1eb575d4eb6d6dfc550a87a183f8b94e76181 320-libffi-gnulinux.patch
diff --git a/main/gcc/ada-aarch64-multiarch.patch b/main/gcc/ada-aarch64-multiarch.patch
new file mode 100644
index 0000000000..ac60b6f6a2
--- /dev/null
+++ b/main/gcc/ada-aarch64-multiarch.patch
@@ -0,0 +1,16 @@
+--- gcc-6.4.0/gcc/ada/gcc-interface/Makefile.in.orig
++++ gcc-6.4.0/gcc/ada/gcc-interface/Makefile.in
+@@ -2042,13 +2042,8 @@
+ system.ads<system-linux-x86_64.ads
+ ## ^^ Note the above is a pretty-close placeholder.
+
+- ifneq (,$(or $(filter aarch64-linux-gnu, $(shell $(GCC_FOR_TARGET) $(GNATLIBCFLAGS) -print-multiarch)), $(filter ../lib64, $(shell $(GCC_FOR_TARGET) $(GNATLIBCFLAGS) -print-multi-os-directory))))
+ LIBGNAT_TARGET_PAIRS = \
+ $(LIBGNAT_TARGET_PAIRS_COMMON) $(LIBGNAT_TARGET_PAIRS_64)
+- else
+- LIBGNAT_TARGET_PAIRS = \
+- $(LIBGNAT_TARGET_PAIRS_COMMON) $(LIBGNAT_TARGET_PAIRS_32)
+- endif
+
+ TOOLS_TARGET_PAIRS = \
+ mlib-tgt-specific.adb<mlib-tgt-specific-linux.adb \
diff --git a/main/gcc/libada-cross-shared.patch b/main/gcc/libada-cross-shared.patch
deleted file mode 100644
index c4e7ae01d6..0000000000
--- a/main/gcc/libada-cross-shared.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- gcc-4.8.2/libada/configure.ac.orig 2013-01-14 22:15:04.000000000 +0400
-+++ gcc-4.8.2/libada/configure.ac 2014-01-21 06:53:04.254453731 +0400
-@@ -127,7 +127,7 @@
- AC_PROG_LN_S
-
- # Determine what to build for 'gnatlib'
--if test $build = $target \
-+if true \
- && test ${enable_shared} = yes ; then
- # Note that build=target is almost certainly the wrong test; FIXME
- default_gnatlib_target="gnatlib-shared"
---- gcc-4.8.2/libada/configure.orig 2013-10-16 11:27:58.000000000 +0400
-+++ gcc-4.8.2/libada/configure 2014-01-21 06:53:26.727581207 +0400
-@@ -2951,7 +2951,7 @@
-
-
- # Determine what to build for 'gnatlib'
--if test $build = $target \
-+if true \
- && test ${enable_shared} = yes ; then
- # Note that build=target is almost certainly the wrong test; FIXME
- default_gnatlib_target="gnatlib-shared"