aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2020-02-08 00:28:41 +0200
committerTimo Teräs <timo.teras@iki.fi>2020-02-08 00:28:41 +0200
commit816c29cacc08ddacd005a95e08e22645bccf832d (patch)
tree7198953ad72796737f6010ce06abb4903d1215e5 /main/gcc
parent4897a6512b5e4dbd06a02ca2a82a6e027261666a (diff)
downloadaports-816c29cacc08ddacd005a95e08e22645bccf832d.tar.bz2
aports-816c29cacc08ddacd005a95e08e22645bccf832d.tar.xz
main/gcc: fix cross-compiler so script generation
The quoting was converted incorrectly and produced invalid files. Fixes: bcca4ab2 "main/gcc: Fix most linting issues"
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 349e31d98e..2f62f48972 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -385,7 +385,7 @@ package() {
# linker finds the libs from relocated sysroot
for so in "$pkgdir"/usr/"$CTARGET"/lib/*.so; do
if [ -h "$so" ]; then
- local _real=$(basename "$(readlink \"$so\")")
+ local _real=$(basename "$(readlink "$so")")
rm -f "$so"
echo "GROUP ($_real)" > "$so"
fi