aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-01-02 19:20:58 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-03 09:29:15 +0000
commit8ecdc06d570e1df1b9bfae022660dfbe98d98106 (patch)
tree34163afd9adbde6e633f875a1dd4dacab6bcd526 /main/gcc
parent5b20e1597ceb8a83bf74f8913d30a7bc80ea52aa (diff)
downloadaports-8ecdc06d570e1df1b9bfae022660dfbe98d98106.tar.bz2
aports-8ecdc06d570e1df1b9bfae022660dfbe98d98106.tar.xz
main/gcc: add patch to fix libgomp relocation on musl, bump pkgrel
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/0016-invalid_tls_model.patch25
-rw-r--r--main/gcc/APKBUILD6
2 files changed, 29 insertions, 2 deletions
diff --git a/main/gcc/0016-invalid_tls_model.patch b/main/gcc/0016-invalid_tls_model.patch
new file mode 100644
index 0000000000..93dd7ddcdf
--- /dev/null
+++ b/main/gcc/0016-invalid_tls_model.patch
@@ -0,0 +1,25 @@
+--- ./libgomp/configure.tgt.orig 2018-09-25 13:44:16.654561098 -0400
++++ ./libgomp/configure.tgt 2018-09-25 13:44:50.452688100 -0400
+@@ -10,23 +10,6 @@
+ # XCFLAGS Add extra compile flags to use.
+ # XLDFLAGS Add extra link flags to use.
+
+-# Optimize TLS usage by avoiding the overhead of dynamic allocation.
+-if test $gcc_cv_have_tls = yes ; then
+- case "${target}" in
+-
+- *-*-k*bsd*-gnu*)
+- ;;
+-
+- *-*-linux* | *-*-gnu*)
+- XCFLAGS="${XCFLAGS} -ftls-model=initial-exec"
+- ;;
+-
+- *-*-rtems*)
+- XCFLAGS="${XCFLAGS} -ftls-model=local-exec"
+- ;;
+- esac
+-fi
+-
+ # Since we require POSIX threads, assume a POSIX system by default.
+ config_path="posix"
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index c528005ea1..c713e1d490 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -6,7 +6,7 @@ pkgver=8.2.0
[ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
pkgname="$pkgname$_target"
-pkgrel=1
+pkgrel=2
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -172,6 +172,7 @@ source="https://gcc.gnu.org/pub/gcc/releases/gcc-${_pkgbase:-$pkgver}/gcc-${_pkg
320-libffi-gnulinux.patch
gcc-pure64-mips.patch
+ 0016-invalid_tls_model.patch
"
# gcc-4.8-build-args.patch
@@ -583,4 +584,5 @@ fa62556719449caec6b2b434355bfbcaa5ae55ffe017b3e1f827f66a2aae21b79c571ee7a4ce723e
50537add461714f44dc6a778e0c6d0e15d6a782591c8aff38d1fb559191ddac2b5ee14a43a3005b389fdf98d2e7468ff4e64c88ba024cf94f9fe0d9854b9e9c8 ada-musl.patch
a1f7750bc7b8b7d916a5dee34fcc736bd4fb249c96538b547d495794e6cfd49356aa3974506a15074b4cb58edd5d7e2868607c902dd003e8c464d5066fd4a575 libgnarl-musl.patch
f4ef08454e28c8732db69115e4998ec153399e8d229dd27f923dbdcf57b68128a65640d026cc7f45b58ba8764ab1eb575d4eb6d6dfc550a87a183f8b94e76181 320-libffi-gnulinux.patch
-86be3338cc9c33089608bc4c5e3b7918c4e500a345c338f361b18c342119a6ed69af5495d72950de7106d760f003528b46ad14795e805f8a3331e206dcb234e3 gcc-pure64-mips.patch"
+86be3338cc9c33089608bc4c5e3b7918c4e500a345c338f361b18c342119a6ed69af5495d72950de7106d760f003528b46ad14795e805f8a3331e206dcb234e3 gcc-pure64-mips.patch
+8039d4081b77332694bc10f898d5e4da0ece4ce7b0e219fedb2aab965126b6b0537d03ba8652341c9c35af07eef33e96b42cc02388f36d8027b9475d44f6b420 0016-invalid_tls_model.patch"