aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2020-02-17 18:48:25 +0000
committerAriadne Conill <ariadne@dereferenced.org>2020-02-17 18:54:28 +0000
commitd7cdb1931ee1511a6c3dcc3f24b0b23689caf310 (patch)
tree5e9b921729a1fb617018553b216d915397b07536 /main/gcc
parent6081d72ed6310a9551a5831e510a538ebd68ebe8 (diff)
downloadaports-d7cdb1931ee1511a6c3dcc3f24b0b23689caf310.tar.bz2
aports-d7cdb1931ee1511a6c3dcc3f24b0b23689caf310.tar.xz
main/gcc: disable D support on mips for now
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index d9fc8e1c2f..8dec4e05fe 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -93,6 +93,11 @@ fi
# See libphobos/configure.tgt in GCC sources for supported targets
[ "$CARCH" = ppc64le ] && LANG_D=false
+# GDC requires libucontext on mips, which is not yet available
+case "$CTARGET_ARCH" in
+mips*) LANG_D=false ;;
+esac
+
# Go needs {set,make,swap}context, unimplemented in musl
[ "$CTARGET_LIBC" = musl ] && LANG_GO=false