aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2018-02-24 12:53:40 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-27 20:55:55 +0000
commite0a466a5cafce4fcac3763df56c02e19ef9f6106 (patch)
tree43ec5d038b31d1a89d672b601d8a37c39f70511c /main/gcc
parent721bc20afa26d524e6801d7ac63101ff3f723d79 (diff)
downloadaports-e0a466a5cafce4fcac3763df56c02e19ef9f6106.tar.bz2
aports-e0a466a5cafce4fcac3763df56c02e19ef9f6106.tar.xz
main/gcc: fix c89/c99 wrappers
Prevent variables in the here-document from being expanded. Keep indentation and use $() for consistency.
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index e5ffb0abf0..9838eefeb2 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -6,7 +6,7 @@ pkgver=6.4.0
[ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
pkgname="$pkgname$_target"
-pkgrel=6
+pkgrel=7
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -393,7 +393,7 @@ package() {
done
else
# add c89/c99 wrapper scripts
- cat >"$pkgdir"/usr/bin/c89 <<EOF
+ cat >"$pkgdir"/usr/bin/c89 <<'EOF'
#!/bin/sh
fl="-std=c89"
for opt; do
@@ -405,13 +405,13 @@ for opt; do
done
exec gcc $fl ${1+"$@"}
EOF
- cat >"$pkgdir"/usr/bin/c99 <<-EOF
+ cat >"$pkgdir"/usr/bin/c99 <<'EOF'
#!/bin/sh
fl="-std=c99"
for opt; do
case "$opt" in
-std=c99|-std=iso9899:1999) fl="";;
- -std=*) echo "`basename $0` called with non ISO C99 option $opt" >&2
+ -std=*) echo "$(basename $0) called with non ISO C99 option $opt" >&2
exit 1;;
esac
done