aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorNils Andreas Svee <me@lochnair.net>2017-12-10 01:18:10 +0100
committerTimo Teräs <timo.teras@iki.fi>2017-12-11 09:01:21 +0200
commitf3c61cdf41a9d3de593e053cb8fcf9bff00069d2 (patch)
tree61872e6a3830365e672600af99418b600902adcd /main/gcc
parentae2509ae4bd6bc210bd61584e4ce94925458b658 (diff)
downloadaports-f3c61cdf41a9d3de593e053cb8fcf9bff00069d2.tar.bz2
aports-f3c61cdf41a9d3de593e053cb8fcf9bff00069d2.tar.xz
main/gcc: disable .gnu_hash on MIPS archs
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index f452f7c35c..83243c2c28 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -243,6 +243,11 @@ build() {
s390x-*-*-*) _arch_configure="--with-arch=z196 --with-tune=zEC12 --with-zarch --with-long-double-128 --enable-decimal-float";;
esac
+ case "$CTARGET_ARCH" in
+ mips*) _hash_style_configure="--with-linker-hash-style=sysv" ;;
+ *) _hash_style_configure="--with-linker-hash-style=gnu" ;;
+ esac
+
case "$CTARGET_LIBC" in
musl)
# musl does not support mudflap, or libsanitizer
@@ -279,6 +284,7 @@ build() {
echo " libc_configure=$_libc_configure"
echo " cross_configure=$_cross_configure"
echo " bootstrap_configure=$_bootstrap_configure"
+ echo " hash_style_configure=$_hash_style_configure"
echo ""
mkdir -p "$_builddir"
@@ -306,7 +312,7 @@ build() {
$_cross_configure \
$_bootstrap_configure \
--with-system-zlib \
- --with-linker-hash-style=gnu
+ $_hash_style_configure
make
}