aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcr
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-19 09:41:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-19 09:43:59 +0000
commita1c6e223d25b00fd537fba715b9aefab56ed0017 (patch)
tree03b53c4a7b353cddc430c374ae3ce6b834cf14ca /main/gcr
parentd6ac8731d1d6ea26997c362f21873c4cf35ceb5a (diff)
downloadaports-a1c6e223d25b00fd537fba715b9aefab56ed0017.tar.bz2
aports-a1c6e223d25b00fd537fba715b9aefab56ed0017.tar.xz
main/gcr: fix circular build time dependency
drop tests that requires gnupg to avoid the circular dependency: gcr -> gnupg -> pinentry ->gcr We also skip tests that requires xvfb-run/dbus to keep things simple.
Diffstat (limited to 'main/gcr')
-rw-r--r--main/gcr/APKBUILD26
1 files changed, 24 insertions, 2 deletions
diff --git a/main/gcr/APKBUILD b/main/gcr/APKBUILD
index 5d8d2a774c..1c6de14883 100644
--- a/main/gcr/APKBUILD
+++ b/main/gcr/APKBUILD
@@ -10,7 +10,7 @@ arch="all"
license="LGPL-2.0-or-later"
makedepends="glib-dev gtk+3.0-dev libgcrypt-dev p11-kit-dev
gobject-introspection-dev libxslt vala"
-checkdepends="xvfb-run gnupg dbus-x11"
+checkdepends="python3"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-base"
source="https://download.gnome.org/sources/gcr/${pkgver%.*}/gcr-$pkgver.tar.xz
remove-failing-test.patch"
@@ -30,7 +30,29 @@ build() {
}
check() {
- xvfb-run make check
+ # only run tests that does not require gnupg to avoid circular dependency:
+ # gcr -> gnupg -> pinentry -> gcr
+ make check TESTS="
+ test-asn1 test-asn1x test-dn
+ test-decimal test-hex test-hkdf
+ test-oid test-secmem test-padding
+ test-symkey test-armor test-openssl
+ test-dh
+ test-gck-attributes test-gck-module
+ test-gck-slot test-gck-session
+ test-gck-object test-gck-crypto
+ test-gck-uri test-gck-enumerator
+ test-gck-modules
+ test-secret-exchange test-simple-certificate
+ test-certificate test-certificate-chain
+ test-subject-public-key test-fingerprint
+ test-pkcs11-certificate test-openpgp
+ test-openssh test-secure-memory
+ test-trust test-parser
+ test-memory-icon test-gnupg-key
+ test-gnupg-process
+ test-ssh-askpass
+ "
}
package() {