aboutsummaryrefslogtreecommitdiffstats
path: root/main/geoip
diff options
context:
space:
mode:
authorDaniel Isaksen <d@duniel.no>2018-01-28 19:08:40 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-02-12 09:58:37 +0000
commit46026ea826f5d0507f85a9800b220e47da7b1206 (patch)
tree5d494f847a8cc5d38a95bb673b0a7a4ba55533e4 /main/geoip
parent686332495415a6dd39768ab832e74d04f968b58c (diff)
downloadaports-46026ea826f5d0507f85a9800b220e47da7b1206.tar.bz2
aports-46026ea826f5d0507f85a9800b220e47da7b1206.tar.xz
main/geoip: download additional databases from MaxMind
Modernize APKBUILD
Diffstat (limited to 'main/geoip')
-rw-r--r--main/geoip/APKBUILD15
-rwxr-xr-xmain/geoip/geoip.cron5
2 files changed, 10 insertions, 10 deletions
diff --git a/main/geoip/APKBUILD b/main/geoip/APKBUILD
index e095b34758..dcde2c3a59 100644
--- a/main/geoip/APKBUILD
+++ b/main/geoip/APKBUILD
@@ -1,22 +1,17 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname="geoip"
-_realname="GeoIP"
+_pkgname="GeoIP"
pkgver=1.6.12
-pkgrel=0
+pkgrel=1
pkgdesc="Lookup countries by IP addresses"
url="http://www.maxmind.com/app/ip-location"
arch="all"
license="GPL"
makedepends="zlib-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/maxmind/geoip-api-c/releases/download/v$pkgver/$_realname-$pkgver.tar.gz
+source="https://github.com/maxmind/geoip-api-c/releases/download/v$pkgver/$_pkgname-$pkgver.tar.gz
geoip.cron"
-builddir="$srcdir"/$_realname-$pkgver
-
-prepare() {
- cd "$builddir"
- return 0
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
@@ -43,4 +38,4 @@ check() {
}
sha512sums="a1c8120692a7ba6de5836550917f86f4797dd236a8b7d71b6f92b5389e4b071d89e57036654f5de1d4b762730a2a5c331c31414eab0c889c9befaa097941fee7 GeoIP-1.6.12.tar.gz
-5fc4003b57f5a0514c42764a6c6d28c2db926ea244f125accf490648adc9d172215e0d16426f49d79e1c465fea2c71b591636f1038d683c77535d2d93811a73e geoip.cron"
+910b1efc93898416057aa7fc1a3f57d35f354973656ed40fbe266c737c4b4aa37f28b42e4163ed850a454c999bc880c27d863a04a14328b7b7e65348a85dd7d3 geoip.cron"
diff --git a/main/geoip/geoip.cron b/main/geoip/geoip.cron
index fc96d08a82..8d74aff5cf 100755
--- a/main/geoip/geoip.cron
+++ b/main/geoip/geoip.cron
@@ -1,2 +1,7 @@
#!/bin/sh
wget -q http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz -O /tmp/GeoIP.dat.gz && gunzip /tmp/GeoIP.dat.gz && mv /tmp/GeoIP.dat /usr/share/GeoIP
+wget -q http://geolite.maxmind.com/download/geoip/database/GeoIPv6.dat.gz -O /tmp/GeoIPv6.dat.gz && gunzip /tmp/GeoIPv6.dat.gz && mv /tmp/GeoIPv6.dat /usr/share/GeoIP
+wget -q http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz -O /tmp/GeoLiteCity.dat.gz && gunzip /tmp/GeoLiteCity.dat.gz && mv /tmp/GeoLiteCity.dat /usr/share/GeoIP
+wget -q http://geolite.maxmind.com/download/geoip/database/GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz -O /tmp/GeoLiteCityv6.dat.gz && gunzip /tmp/GeoLiteCityv6.dat.gz && mv /tmp/GeoLiteCityv6.dat /usr/share/GeoIP
+wget -q http://geolite.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz -O /tmp/GeoIPASNum.dat.gz && gunzip /tmp/GeoIPASNum.dat.gz && mv /tmp/GeoIPASNum.dat /usr/share/GeoIP
+wget -q http://geolite.maxmind.com/download/geoip/database/asnum/GeoIPASNumv6.dat.gz -O /tmp/GeoIPASNumv6.dat.gz && gunzip /tmp/GeoIPASNumv6.dat.gz && mv /tmp/GeoIPASNumv6.dat /usr/share/GeoIP