aboutsummaryrefslogtreecommitdiffstats
path: root/main/ghi
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-06-16 23:03:58 -0300
committerTimo Teräs <timo.teras@iki.fi>2017-06-19 13:19:18 +0000
commit93b7af3e5ca2515c68f693fb50fa9a48b1c09fd1 (patch)
tree52cf69e5fced73d68b160eb02de5142bf9b21b0d /main/ghi
parentb8cea504a0c1ccdb40ea1f9b006ea90c5a992f39 (diff)
downloadaports-93b7af3e5ca2515c68f693fb50fa9a48b1c09fd1.tar.bz2
aports-93b7af3e5ca2515c68f693fb50fa9a48b1c09fd1.tar.xz
main/ghi: upgrade to 1.2.0
Diffstat (limited to 'main/ghi')
-rw-r--r--main/ghi/APKBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/main/ghi/APKBUILD b/main/ghi/APKBUILD
index 90ab4207f9..17aa730f14 100644
--- a/main/ghi/APKBUILD
+++ b/main/ghi/APKBUILD
@@ -1,32 +1,27 @@
# Maintainer: Eivind Uggedal <eivind@uggedal.com>
pkgname=ghi
-pkgver=0.9.3
+pkgver=1.2.0
pkgrel=0
pkgdesc="GitHub Issues on the command line"
url="https://github.com/stephencelis/ghi"
arch="noarch"
license="MIT"
depends="ruby ncurses"
-makedepends=""
-install=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/stephencelis/ghi/archive/$pkgver.tar.gz"
-_builddir="$srcdir/$pkgname-$pkgver"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
-
- sed -n '/(<stephen@stephencelis.com>).$/,$p' README.markdown > LICENSE
+ return 0
}
package() {
- cd "$_builddir"
+ cd "$builddir"
install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
install -D -m644 man/$pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-md5sums="e6670a27bcbd09f6600a4efd1d56b4c4 ghi-0.9.3.tar.gz"
-sha256sums="1b58c7ec6e9339c44175808719694d7ee21cbd254d3a2e6d31a70d31027e9bea ghi-0.9.3.tar.gz"
-sha512sums="660dfb0cb6db7df0c5c20821b9b968240dd96c0ea2143b15049aa1f2a9e40d071de16f971c1d5e61b5c666f76b078d639e0fca8bac8ff0135ea84d8963bcb8af ghi-0.9.3.tar.gz"
+
+sha512sums="345f3325007cef9087cb9c0215a2412c09aec542bec8003f2d67c3870fce36078a6ba2c8b73377cac419f82cbf8aed6ddab57ac96622aa2917734ae738014b89 ghi-1.2.0.tar.gz"