aboutsummaryrefslogtreecommitdiffstats
path: root/main/ghostscript
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-05-03 00:00:50 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-03 15:02:21 +0000
commit9851d3d1c95aa9814cddecf0325fb778782b9502 (patch)
tree754051316a0e91391a6821e854a8393a006cd44e /main/ghostscript
parentb0cd6f41b8efe0593b9dd48fd0c96d034cc115a0 (diff)
downloadaports-9851d3d1c95aa9814cddecf0325fb778782b9502.tar.bz2
aports-9851d3d1c95aa9814cddecf0325fb778782b9502.tar.xz
main/ghostscript: fix incorrect checksums and improve abuild
Diffstat (limited to 'main/ghostscript')
-rw-r--r--main/ghostscript/APKBUILD38
1 files changed, 18 insertions, 20 deletions
diff --git a/main/ghostscript/APKBUILD b/main/ghostscript/APKBUILD
index 426f7b876c..36f68533b0 100644
--- a/main/ghostscript/APKBUILD
+++ b/main/ghostscript/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Cameron Banta <cbanta@gmail.com>
pkgname=ghostscript
pkgver=9.19
-pkgrel=0
+pkgrel=1
pkgdesc="An interpreter for the PostScript language and for PDF"
url="http://ghostscript.com/"
arch="all"
@@ -15,16 +15,13 @@ source="https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/
ghostscript-system-zlib.patch
fix-sprintf.patch
"
-
# ghostscript-system-openjpeg2.patch
-_builddir="$srcdir/ghostscript-$pkgver"
+builddir="$srcdir/ghostscript-$pkgver"
+
prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ cd "$builddir"
+
+ default_prepare || return 1 # apply patches
# force it to use system-libs
rm -r jpeg libpng zlib tiff lcms2 cups/libs jbig2dec \
@@ -34,15 +31,15 @@ prepare() {
sed -i -e 's/ECHO_XE/ECHOGS_XE/g' \
-e 's/^\($(GLOBJ)md5.$(OBJ) :.*\)/\1 $(ECHOGS_XE)/' \
base/lib.mak || return 1
- aclocal && autoconf --force
+ aclocal && autoconf --force || return 1
- cd $_builddir/ijs
+ cd $builddir/ijs
libtoolize --force && aclocal && autoconf && automake --add-missing
}
build(){
# build ijs
- cd "$_builddir"/ijs
+ cd "$builddir"/ijs
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -50,9 +47,9 @@ build(){
--enable-shared \
--disable-static \
|| return 1
- make
+ make || return 1
- cd "$_builddir"
+ cd "$builddir"
# --disable-compile-inits is needed to link with system-zlib
./configure \
@@ -74,14 +71,14 @@ build(){
--with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts \
--disable-compile-inits \
|| return 1
- make so all || return 1
+ make so all
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make -j1 DESTDIR="${pkgdir}" install soinstall || return 1
- cd "$_builddir"/ijs
+ cd "$builddir"/ijs
make -j1 DESTDIR="${pkgdir}" install || return 1
cd..
@@ -104,16 +101,17 @@ package() {
gtk() {
pkgdesc="A GTK-enabled PostScript interpreter and renderer"
+
install -d "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/gsx "$subpkgdir"/usr/bin/
}
-md5sums="cd0cb042a020df2e9f30fcce177e9cec ghostscript-9.19.tar.gz
+md5sums="c9682ce6b852f9197c69905a43928907 ghostscript-9.19.tar.gz
ae582371ec56fd8f73349773f23dcc94 ghostscript-system-zlib.patch
ee7da55d7a714db1de0fa78253cdacf3 fix-sprintf.patch"
-sha256sums="fc07d5eb1b325f59d4bb3994975e9ab769e7c7353403c6420f42c54161c552ca ghostscript-9.19.tar.gz
+sha256sums="cf3c0dce67db1557a87366969945f9c5235887989c0b585e037af366dc035989 ghostscript-9.19.tar.gz
56662fae7956e741059ef9c2b5a7e883ab04d78acf5dae4fddf4a661f47f8b67 ghostscript-system-zlib.patch
6e01bd26ade307414f86a5d8f00c97719830d8afd49ffe84224ae47498de7a54 fix-sprintf.patch"
-sha512sums="1f922cb8c27450f7c7c3ae0f9603574cbe25cb0c495d3707ab0c37b0c42061f2c68c7c80ebdac63c3165eb953f201440e4a0e3f73bb7c3331422cae3907738fb ghostscript-9.19.tar.gz
+sha512sums="7575564be7596340af7eb0993d3d8ad5d6ba5fea0c07f470c88b280c0bef1c0dba9875d8ecc84fd87177915fd6166bc7db5929e4f053ba33472eae01b818e0ab ghostscript-9.19.tar.gz
70721e3a335afa5e21d4e6cf919119010bd4544a03ab8f53f5325c173902221ad9b88c118b4bfeee80b3e1956bcdbaf4c53f64ae7fb81f5ba57dbc956750c482 ghostscript-system-zlib.patch
beefcf395f7f828e1b81c088022c08a506e218f27535b9de01e0f0edf7979b435316c318fa676771630f6ad16ff1ab059cd68aa128ed97e5a9f2f3fa840200c4 fix-sprintf.patch"