aboutsummaryrefslogtreecommitdiffstats
path: root/main/glade
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-29 11:21:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-29 11:21:20 +0000
commit0c8949b786bbd123621f392d6731dc3dd690f5ef (patch)
tree51bfc00d88c0af2c36ef00b04071e57661b92e75 /main/glade
parent4aabe39a9fa8aa8699e0dbad044352b228be19c4 (diff)
downloadaports-0c8949b786bbd123621f392d6731dc3dd690f5ef.tar.bz2
aports-0c8949b786bbd123621f392d6731dc3dd690f5ef.tar.xz
main/glade: moved from testing
Diffstat (limited to 'main/glade')
-rw-r--r--main/glade/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/main/glade/APKBUILD b/main/glade/APKBUILD
new file mode 100644
index 0000000000..e30addc1cf
--- /dev/null
+++ b/main/glade/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=glade
+pkgver=3.10.0
+pkgrel=2
+pkgdesc="User Interface Designer for GTK+ and GNOME"
+url="http://glade.gnome.org/"
+arch="all"
+license="GPL"
+depends=
+makedepends="gtk+3.0-dev libxml2-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.gnome.org/pub/GNOME/sources/glade/${pkgver%.*}/glade-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" -name '*.la' -delete
+}
+
+md5sums="70c61582bdc6e9a852b29f3d172ddd4e glade-3.10.0.tar.bz2"