aboutsummaryrefslogtreecommitdiffstats
path: root/main/glu
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-05 19:04:29 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-07 08:37:43 +0000
commit3a845e8ec6e10c3df67198bd5a55fabea34ec5bf (patch)
tree48cc3df8e79d5fbba090c68e7ac896c285afddfb /main/glu
parent224502d179b100b22c7ef6a7a66d8a54cade0fc6 (diff)
downloadaports-3a845e8ec6e10c3df67198bd5a55fabea34ec5bf.tar.bz2
aports-3a845e8ec6e10c3df67198bd5a55fabea34ec5bf.tar.xz
main/glu: modernise, fix license, mark no tests
Diffstat (limited to 'main/glu')
-rw-r--r--main/glu/APKBUILD28
1 files changed, 11 insertions, 17 deletions
diff --git a/main/glu/APKBUILD b/main/glu/APKBUILD
index d01d350119..47c2116a53 100644
--- a/main/glu/APKBUILD
+++ b/main/glu/APKBUILD
@@ -1,11 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glu
pkgver=9.0.0
-pkgrel=3
+pkgrel=4
pkgdesc="Mesa OpenGL Utility library"
url="https://cgit.freedesktop.org/mesa/glu/"
arch="all"
-license="LGPL"
+options="!check" # No test suite.
+license="SGI-B-1.1 AND SGI-B-2.0"
depends=""
depends_dev="mesa-dev"
makedepends="$depends_dev"
@@ -14,32 +15,25 @@ replaces="mesa-glu"
subpackages="$pkgname-dev"
source="ftp://ftp.freedesktop.org/pub/mesa/glu/glu-$pkgver.tar.bz2"
-_builddir="$srcdir"/glu-$pkgver
prepare() {
- local i
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ cd "$builddir"
+ update_config_sub
+ default_prepare
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --disable-static \
- || return 1
- make || return 1
+ --disable-static
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
sha512sums="ff920e3fbca739794e1432a92fdd8517aa732110fea71ed724185425042f83ce18e9866c16f95c6e10f6993f0814a90fac9636e2b3d8ca2084d1ac0a860f61c8 glu-9.0.0.tar.bz2"