aboutsummaryrefslogtreecommitdiffstats
path: root/main/gnokii/APKBUILD
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-12 16:22:51 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-13 10:54:05 +0000
commit6df1ab7a7ed137621f0e2e4b7c49cbcd3bbaa449 (patch)
tree2676e7c8b01fcdfce3fea439c5ec8bea5de93c10 /main/gnokii/APKBUILD
parentadc6edea388834f48c54218a144b713c76dea505 (diff)
downloadaports-6df1ab7a7ed137621f0e2e4b7c49cbcd3bbaa449.tar.bz2
aports-6df1ab7a7ed137621f0e2e4b7c49cbcd3bbaa449.tar.xz
main/gnokii: build fix for gcc8
This is yet another package that assumes GNU-style inline keyword handling and fails with the "undefined reference to `foo'" linker error where foo is some inline function (here local_atoi). Instead of fixing the source, pass -std=gnu89 in CFLAGS because 1) this is shorter and easier; 2) the project is actually written in GNU C89 dialect; 3) upstream is not active (the last release was in 2011). With this change in place gnokii-0.6.31-gcc5.patch can be removed, suggesting the -std=gnu89 approach is also more future-proof for any further changes in compiler's inliner implementation.
Diffstat (limited to 'main/gnokii/APKBUILD')
-rw-r--r--main/gnokii/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/gnokii/APKBUILD b/main/gnokii/APKBUILD
index 21be793db9..7a5ca16d3b 100644
--- a/main/gnokii/APKBUILD
+++ b/main/gnokii/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnokii
pkgver=0.6.31
-pkgrel=7
+pkgrel=8
pkgdesc="Tools and user space driver for use with mobile phones"
url="http://www.gnokii.org/"
arch="all"
@@ -36,6 +36,7 @@ prepare() {
build() {
cd "$_builddir"
+ CFLAGS="$CFLAGS -std=gnu89" \
./configure \
--build=$CBUILD \
--host=$CHOST \