aboutsummaryrefslogtreecommitdiffstats
path: root/main/gnutls
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-13 23:37:26 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-13 23:55:07 +0200
commit533caace2cc54689a68d4f5ffa16e5b8c1972e14 (patch)
treed3af00bec6a9bf06fb90fa35dc169121b149631b /main/gnutls
parent37cde2005d513c433cefe6fc7fa73021c02606ab (diff)
downloadaports-533caace2cc54689a68d4f5ffa16e5b8c1972e14.tar.bz2
aports-533caace2cc54689a68d4f5ffa16e5b8c1972e14.tar.xz
main/gnutls: patch tests/scripts/common.sh instead of using coreutils
It passed on my machine and some builders, so there's something wrong on x86 and x86_64 builders. However, this method is better anyway.
Diffstat (limited to 'main/gnutls')
-rw-r--r--main/gnutls/APKBUILD8
-rw-r--r--main/gnutls/tests-date-compat.patch12
2 files changed, 17 insertions, 3 deletions
diff --git a/main/gnutls/APKBUILD b/main/gnutls/APKBUILD
index fea32fab75..96cde0122d 100644
--- a/main/gnutls/APKBUILD
+++ b/main/gnutls/APKBUILD
@@ -8,14 +8,15 @@ pkgdesc="A TLS protocol implementation"
url="http://www.gnutls.org/"
arch="all"
license="GPL"
-checkdepends="coreutils diffutils"
+checkdepends="diffutils"
makedepends="nettle-dev zlib-dev libtasn1-dev p11-kit-dev libunistring-dev texinfo"
subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev $pkgname-utils $pkgname-c++:xx"
_v=${pkgver%.*}
case $pkgver in
*.*.*.*) _v=${_v%.*};;
esac
-source="ftp://ftp.gnutls.org/gcrypt/gnutls/v${_v}/$pkgname-$pkgver.tar.xz"
+source="ftp://ftp.gnutls.org/gcrypt/gnutls/v${_v}/$pkgname-$pkgver.tar.xz
+ tests-date-compat.patch"
builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
@@ -61,4 +62,5 @@ xx() {
mv "$pkgdir"/usr/lib/lib*xx.so.* "$subpkgdir"/usr/lib/
}
-sha512sums="e5f36d7e8d64e8432098e30549c321745d3605eeb85aba2a04bfa92146ca771961f0e2f3682bcae36be5b6095acd25996104a4213ce7b3466d61332a5188dc03 gnutls-3.6.0.tar.xz"
+sha512sums="e5f36d7e8d64e8432098e30549c321745d3605eeb85aba2a04bfa92146ca771961f0e2f3682bcae36be5b6095acd25996104a4213ce7b3466d61332a5188dc03 gnutls-3.6.0.tar.xz
+14b1be86a0180c914aaaada261ccf01914d48df9510b57572e4f32683d1dd984a907ecf2c848cc4773b1c139059de26383a2c617f509f8c75b985668a23fd28d tests-date-compat.patch"
diff --git a/main/gnutls/tests-date-compat.patch b/main/gnutls/tests-date-compat.patch
new file mode 100644
index 0000000000..2717ab230e
--- /dev/null
+++ b/main/gnutls/tests-date-compat.patch
@@ -0,0 +1,12 @@
+Busybox date does not support %N, this is GNU extension.
+--- a/tests/scripts/common.sh
++++ b/tests/scripts/common.sh
+@@ -59,7 +59,7 @@
+ }
+
+ # Find a port number not currently in use.
+-GETPORT='rc=0; myrandom=$(date +%N | sed s/^0*//)
++GETPORT='rc=0; myrandom=$(date +%s | sed s/^0*//)
+ while test $rc = 0;do
+ PORT="$(((($$<<15)|$myrandom) % 63001 + 2000))"
+ check_if_port_in_use $PORT;rc=$?