aboutsummaryrefslogtreecommitdiffstats
path: root/main/gobject-introspection
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-04-24 16:09:04 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-17 10:14:28 +0000
commit47cab035a106ac8d97a95fcbab91267e1d8ede48 (patch)
tree094b1ba2c07bfa67cd090b109f8ce8f64bcbbbae /main/gobject-introspection
parent79d9372490dbf1cf2eb20f4bf914c69db4bf0d56 (diff)
downloadaports-47cab035a106ac8d97a95fcbab91267e1d8ede48.tar.bz2
aports-47cab035a106ac8d97a95fcbab91267e1d8ede48.tar.xz
main/gobject-introspection: upgrade to 1.60.2
* Adopt maintainership * Fix license * Use meson instead of autotools
Diffstat (limited to 'main/gobject-introspection')
-rw-r--r--main/gobject-introspection/APKBUILD32
1 files changed, 16 insertions, 16 deletions
diff --git a/main/gobject-introspection/APKBUILD b/main/gobject-introspection/APKBUILD
index 2d7d4a26e9..0344fb322e 100644
--- a/main/gobject-introspection/APKBUILD
+++ b/main/gobject-introspection/APKBUILD
@@ -1,37 +1,37 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gobject-introspection
-pkgver=1.60.1
+pkgver=1.60.2
pkgrel=0
pkgdesc="Introspection system for GObject-based libraries"
url="https://wiki.gnome.org/action/show/Projects/GObjectIntrospection"
arch="all"
-license="LGPL-2.0+, GPL-2.0+, MIT"
+license="LGPL-2.0-or-later AND GPL-2.0-or-later AND MIT"
depends_dev="python3 cairo-dev libtool"
-makedepends="$depends_dev glib-dev libffi-dev flex bison python3-dev"
+makedepends="$depends_dev glib-dev libffi-dev flex bison python3-dev meson"
subpackages="$pkgname-doc $pkgname-dev"
replaces="libgirepository"
checkdepends="sed"
source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ meson \
--prefix=/usr \
- --disable-static \
- --with-python=python3
- make V=1
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
}
check() {
- cd "$builddir"
- make check
+ ninja -C output test
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C output install
}
dev() {
@@ -43,4 +43,4 @@ dev() {
replaces="gobject-introspection"
}
-sha512sums="01adbeffee08ff6487f11a303fd7a59a99c36714dce21be9bbae7fd2bf8f080665e830bc3a47566140a6081dc74f6c2f8d8232286759b761f70493545a9d90ea gobject-introspection-1.60.1.tar.xz"
+sha512sums="8e8c1c3a025cb6c18933302ada8cce7c4826f22eef791c80a97abb28379239f8d99312e1237bcea1060f4d5cf65441909b9da434561982209bb4976b1f22529e gobject-introspection-1.60.2.tar.xz"