aboutsummaryrefslogtreecommitdiffstats
path: root/main/gptfdisk
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-06 13:43:00 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-07 08:38:27 +0000
commit031175dc92c51cae01f860064e283c60d1bf8f13 (patch)
tree897fcfce61fe1301cf06775020ac9d38016aa5a6 /main/gptfdisk
parent3a845e8ec6e10c3df67198bd5a55fabea34ec5bf (diff)
downloadaports-031175dc92c51cae01f860064e283c60d1bf8f13.tar.bz2
aports-031175dc92c51cae01f860064e283c60d1bf8f13.tar.xz
main/gptfdisk: modernise, fix license, no tests
Diffstat (limited to 'main/gptfdisk')
-rw-r--r--main/gptfdisk/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/main/gptfdisk/APKBUILD b/main/gptfdisk/APKBUILD
index d92296de9e..b2811a547b 100644
--- a/main/gptfdisk/APKBUILD
+++ b/main/gptfdisk/APKBUILD
@@ -5,24 +5,24 @@ pkgrel=0
pkgdesc="A text-mode partitioning tool that works on Globally Unique Identifier (GUID) Partition Table (GPT) disks"
arch="all"
url="http://www.rodsbooks.com/gdisk/"
-license='GPL2'
+options="!check" # No test suite.
+license="GPL-2.0+"
makedepends="ncurses-dev e2fsprogs-dev popt-dev linux-headers"
subpackages="$pkgname-doc sgdisk"
source="http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/gptfdisk-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
make CXX="${CXX:-g++}" CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS"
}
-package () {
- cd "$_builddir"
+package() {
+ cd "$builddir"
mkdir -p "$pkgdir"/usr/bin "$pkgdir"/usr/share/man/man8
for i in gdisk cgdisk sgdisk fixparts; do
- install $i "$pkgdir"/usr/bin/ || return 1
- install $i.8 "$pkgdir"/usr/share/man/man8/ || return 1
+ install $i "$pkgdir"/usr/bin/
+ install $i.8 "$pkgdir"/usr/share/man/man8/
done
}