aboutsummaryrefslogtreecommitdiffstats
path: root/main/gptfdisk
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-17 23:45:11 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-18 10:39:55 -0300
commit216c7c0bb9aa81e81e0ecd434648b7cc6bf156d8 (patch)
treebb1e6b1a3b91b29f87dfe37cc8f5eda0d428e1ee /main/gptfdisk
parent18bdc2ca1e6ec41aa67a9f65de81d92d8b58925b (diff)
downloadaports-216c7c0bb9aa81e81e0ecd434648b7cc6bf156d8.tar.bz2
aports-216c7c0bb9aa81e81e0ecd434648b7cc6bf156d8.tar.xz
main/gptfdisk: upgrade to 1.0.5
Diffstat (limited to 'main/gptfdisk')
-rw-r--r--main/gptfdisk/APKBUILD14
-rw-r--r--main/gptfdisk/fix-wrong-include.patch16
2 files changed, 23 insertions, 7 deletions
diff --git a/main/gptfdisk/APKBUILD b/main/gptfdisk/APKBUILD
index 3b04136ff1..0e93d5b98f 100644
--- a/main/gptfdisk/APKBUILD
+++ b/main/gptfdisk/APKBUILD
@@ -1,24 +1,23 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gptfdisk
-pkgver=1.0.4
+pkgver=1.0.5
pkgrel=0
-pkgdesc="A text-mode partitioning tool that works on Globally Unique Identifier (GUID) Partition Table (GPT) disks"
+pkgdesc="Text-mode partitioning tool that works on Globally Unique Identifier (GUID) Partition Table (GPT) disks"
arch="all"
url="https://www.rodsbooks.com/gdisk"
options="!check" # No test suite.
license="GPL-2.0-or-later"
makedepends="ncurses-dev e2fsprogs-dev popt-dev linux-headers"
subpackages="$pkgname-doc sgdisk"
-source="https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://downloads.sourceforge.net/project/gptfdisk/gptfdisk/$pkgver/gptfdisk-$pkgver.tar.gz
+ fix-wrong-include.patch
+ "
build() {
- cd "$builddir"
make CXX="${CXX:-g++}" CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS"
}
package() {
- cd "$builddir"
-
mkdir -p "$pkgdir"/usr/bin "$pkgdir"/usr/share/man/man8
local i; for i in gdisk cgdisk sgdisk fixparts; do
install $i "$pkgdir"/usr/bin/
@@ -32,4 +31,5 @@ sgdisk() {
mv "$pkgdir"/usr/bin/sgdisk "$subpkgdir"/usr/bin/
}
-sha512sums="2df6db6974c06a6677a155d32566b8b46dad0df7781131e9018072db9acce5e41f6c4e7024b0e5f236dd43350a63572be34fb4b6fdb580cd9b946619a7a683bf gptfdisk-1.0.4.tar.gz"
+sha512sums="3d3a59e3488dd3d6bda5d103b9ad8b7936752210346b9787ddc936681498fba90577b6ae950c471d09a01bf6405fce32038ff1777c52db0b21e5277737fe3703 gptfdisk-1.0.5.tar.gz
+7bb67d132e53cd66a4ae954b4a78f6841c3cdb60bee7cbbecbe1667b95292513fc1561261861607d79164e592faf2045ae51b08ff74ebb5097ad760280307995 fix-wrong-include.patch"
diff --git a/main/gptfdisk/fix-wrong-include.patch b/main/gptfdisk/fix-wrong-include.patch
new file mode 100644
index 0000000000..d2d601731f
--- /dev/null
+++ b/main/gptfdisk/fix-wrong-include.patch
@@ -0,0 +1,16 @@
+diff --git a/gptcurses.cc b/gptcurses.cc
+index 1b18cf2..4ebfde1 100644
+--- a/gptcurses.cc
++++ b/gptcurses.cc
+@@ -23,11 +23,7 @@
+ #include <iostream>
+ #include <string>
+ #include <sstream>
+-#ifdef __APPLE__
+ #include <ncurses.h>
+-#else
+-#include <ncursesw/ncurses.h>
+-#endif
+ #include "gptcurses.h"
+ #include "support.h"
+