aboutsummaryrefslogtreecommitdiffstats
path: root/main/grub
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-11-26 22:05:43 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-18 07:07:46 +0000
commita544df943366e7ed4cedeb9c9b99d83245c038c2 (patch)
treef2969262ba231655f155bc49eff5f0268e729cb8 /main/grub
parent54b9e8796ba1735e254cf860ba8dd36f74d548eb (diff)
downloadaports-a544df943366e7ed4cedeb9c9b99d83245c038c2.tar.bz2
aports-a544df943366e7ed4cedeb9c9b99d83245c038c2.tar.xz
main/grub: fix build on mips*
Provide some basic mips* support just to allow the build succeed. Disabling on mips* is not an option cause the arch= list becomes too long and ugly. Do not bump pkgrel since no previously built mips* apks exist and change does nothing for other architectures.
Diffstat (limited to 'main/grub')
-rw-r--r--main/grub/APKBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/main/grub/APKBUILD b/main/grub/APKBUILD
index 8d0a307f10..f859f7037c 100644
--- a/main/grub/APKBUILD
+++ b/main/grub/APKBUILD
@@ -23,6 +23,7 @@ case "$CARCH" in
x86) flavors="efi bios";;
x86_64) flavors="efi bios xenhost";;
aarch64|arm*) flavors="efi";;
+mips*) flavors="qemu_mips";;
ppc*) flavors="ieee1275"; makedepends="$makedepends powerpc-utils" ;;
s390x) flavors="emu" ;;
esac
@@ -144,6 +145,13 @@ xenhost() {
mv $pkgdir/*-xen.bin $subpkgdir/usr/lib/grub-xen/
}
+qemu_mips() {
+ pkgdesc="$pkgdesc (QEMU MIPS version)"
+ depends="$pkgname"
+ mkdir -p $subpkgdir/usr/lib/grub
+ mv $pkgdir/usr/lib/grub/*-qemu_mips $subpkgdir/usr/lib/grub/
+}
+
ieee1275() {
pkgdesc="$pkgdesc (IEEE1275 version)"
depends="$pkgname powerpc-utils"