aboutsummaryrefslogtreecommitdiffstats
path: root/main/gst-plugins-bad
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-06-29 09:15:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-29 09:28:37 +0000
commit242d999649e2d2b97394b4ee89c8beae99fb2664 (patch)
tree8f8563df5418d5eea6fc9ed6312c3a0129285774 /main/gst-plugins-bad
parente93445cd21e0a5c315dea792a63569074981e829 (diff)
downloadaports-242d999649e2d2b97394b4ee89c8beae99fb2664.tar.bz2
aports-242d999649e2d2b97394b4ee89c8beae99fb2664.tar.xz
main/gst*1: rename. remove "1" suffix
Diffstat (limited to 'main/gst-plugins-bad')
-rw-r--r--main/gst-plugins-bad/APKBUILD64
1 files changed, 64 insertions, 0 deletions
diff --git a/main/gst-plugins-bad/APKBUILD b/main/gst-plugins-bad/APKBUILD
new file mode 100644
index 0000000000..1fb85f9d65
--- /dev/null
+++ b/main/gst-plugins-bad/APKBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-bad
+pkgver=1.12.0
+pkgrel=0
+pkgdesc="GStreamer bad plugins"
+url="http://gstreamer.freedesktop.org/"
+arch="all"
+license="LGPL GPL"
+depends=""
+subpackages="$pkgname-lang $pkgname-dev $pkgname-doc"
+makedepends="
+ alsa-lib-dev
+ bzip2-dev
+ curl-dev
+ faac-dev
+ faad2-dev
+ flite-dev
+ glib-dev
+ gsm-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ jasper-dev
+ libdc1394-dev
+ libexif-dev
+ libmms-dev
+ libmodplug-dev
+ liboil-dev
+ libressl-dev
+ librsvg-dev
+ libvdpau-dev
+ libx11-dev
+ neon-dev
+ orc-dev
+ sdl-dev
+ spandsp-dev
+ xvidcore-dev
+ "
+source="http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz"
+ldpath="/usr/lib/gstreamer-.0"
+builddir="$srcdir"/gst-plugins-bad-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-experimental \
+ --disable-fatal-warnings \
+ --with-package-name="GStreamer Bad Plugins (Alpine Linux)" \
+ --with-package-origin="http://alpinelinux.org/" \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="c26fbd4cc741daf69b5b12cd2f5c6ce82a06e2f458d8687631785adff1597534899dc37314d6670a349d9aa1653c00b38a08def91a18d1cbfc1f51e9e089a0fb gst-plugins-bad-1.12.0.tar.xz"