aboutsummaryrefslogtreecommitdiffstats
path: root/main/gst-plugins-base
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-04 15:44:30 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-03-06 00:47:45 +0000
commit2c7043003a30256fe6d19c4c5dc167548e28afd1 (patch)
treebfe74bf9b47650c2112b189e50de1424a1084673 /main/gst-plugins-base
parent0bc71137f0fda19d68e20c0e41efa08f834c7c1c (diff)
downloadaports-2c7043003a30256fe6d19c4c5dc167548e28afd1.tar.bz2
aports-2c7043003a30256fe6d19c4c5dc167548e28afd1.tar.xz
main/gst-plugins-base: modernise, add check, fix typo
Diffstat (limited to 'main/gst-plugins-base')
-rw-r--r--main/gst-plugins-base/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/main/gst-plugins-base/APKBUILD b/main/gst-plugins-base/APKBUILD
index 42d28a6e87..9d9e5cbd10 100644
--- a/main/gst-plugins-base/APKBUILD
+++ b/main/gst-plugins-base/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-plugins-base
pkgver=1.12.3
-pkgrel=0
+pkgrel=1
pkgdesc="GStreamer Multimedia Framework Base Plugins"
url="https://gstreamer.freedesktop.org/"
arch="all"
@@ -28,8 +28,9 @@ makedepends="
glib-dev
opus-dev
"
+checkdepends="orc-compiler"
source="https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-$pkgver.tar.xz"
-ldpath="/usr/lib/gstreamer-.0"
+ldpath="/usr/lib/gstreamer-1.0"
builddir="$srcdir"/gst-plugins-base-$pkgver
build() {
@@ -45,15 +46,19 @@ build() {
--disable-fatal-warnings \
--with-default-audiosink=alsasink \
--enable-introspection \
- --with-package-name="GStreamer Base Plugins (Alpine Linux)" \
- --with-package-origin="http://alpinelinux.org/" \
- || return 1
- make || return 1
+ --with-package-name="GStreamer Base Plugins (${DISTRO_NAME:-Alpine Linux})" \
+ --with-package-origin="${DISTRO_URL:-http://alpinelinux.org/}"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ make -j1 DESTDIR="$pkgdir" install
}
doc() {