aboutsummaryrefslogtreecommitdiffstats
path: root/main/gst-plugins-base
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-05-07 15:52:10 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-27 18:45:53 +0000
commitd3648baa692647bef233f410d7af344bf69b6452 (patch)
treee9b999128b5367311ec76f5e3589dd377e8d8405 /main/gst-plugins-base
parenta43c39d804e5ff054f86121e0323ea9c1898d6fe (diff)
downloadaports-d3648baa692647bef233f410d7af344bf69b6452.tar.bz2
aports-d3648baa692647bef233f410d7af344bf69b6452.tar.xz
main/gst-plugins-base: upgrade to 1.16.0
Diffstat (limited to 'main/gst-plugins-base')
-rw-r--r--main/gst-plugins-base/APKBUILD62
1 files changed, 20 insertions, 42 deletions
diff --git a/main/gst-plugins-base/APKBUILD b/main/gst-plugins-base/APKBUILD
index 6961a8f864..8af2afceea 100644
--- a/main/gst-plugins-base/APKBUILD
+++ b/main/gst-plugins-base/APKBUILD
@@ -1,67 +1,45 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-plugins-base
-pkgver=1.14.4
+pkgver=1.16.0
pkgrel=0
-pkgdesc="GStreamer Multimedia Framework Base Plugins"
+pkgdesc="GStreamer streaming media framework base plug-ins"
url="https://gstreamer.freedesktop.org"
arch="all"
license="GPL-2.0-or-later LGPL-2.0-or-later"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-depends=
replaces="gst-plugins-base1 gst-plugins-bad"
-makedepends="
- alsa-lib-dev
- cdparanoia-dev
- expat-dev
- gtk+3.0-dev
- libice-dev
- libogg-dev
- libsm-dev
- libtheora-dev
- libvorbis-dev
- libxv-dev
- orc-dev
- perl
- gobject-introspection-dev
- gstreamer-dev
- glib-dev
- opus-dev
- mesa-dev
- orc-compiler
- "
-source="https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-$pkgver.tar.xz"
+makedepends="alsa-lib-dev cdparanoia-dev expat-dev glib-dev
+ gobject-introspection-dev gstreamer-dev gtk+3.0-dev libice-dev
+ libogg-dev libsm-dev libtheora-dev libvorbis-dev libxv-dev mesa-dev
+ meson opus-dev orc-compiler orc-dev perl"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-base/$pkgname-$pkgver.tar.xz"
ldpath="/usr/lib/gstreamer-1.0"
-builddir="$srcdir"/gst-plugins-base-$pkgver
-# sporadic testsuite failures on various archs, testsuite fails with network restricted too
+# sporadic testsuite failures on various archs, testsuite fails with network
+# restricted too
options="!check"
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ meson \
--prefix=/usr \
--sysconfdir=/etc \
+ --mandir=/usr/share/man \
--localstatedir=/var \
- --disable-static \
- --disable-experimental \
- --disable-fatal-warnings \
- --with-default-audiosink=alsasink \
- --enable-introspection \
- --with-package-name="GStreamer Base Plugins (${DISTRO_NAME:-Alpine Linux})" \
- --with-package-origin="${DISTRO_URL:-http://alpinelinux.org/}"
- make
+ --buildtype=release \
+ -Dalsa=enabled \
+ -Dintrospection=enabled \
+ -Dpackage-origin="https://alpinelinux.org" \
+ -Dpackage-name="GStreamer base plug-ins (Alpine Linux)" \
+ . output
+ ninja -C output
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C output install
}
doc() {
@@ -69,4 +47,4 @@ doc() {
replaces="${pkgname}1-doc"
}
-sha512sums="42c59df9f2d848108f12afa0466acbcfa5ccda64e4d0d44608d4268abed20f2e036713de04e7d71feaed1868ad742c5bcb55ae0eef5dec8e19e053dc8541b8af gst-plugins-base-1.14.4.tar.xz"
+sha512sums="4fa404156a384000e26e72ff0f701edb5a160181b48362350529177ca1c9325a3c58b83904bf5056262fe2609bc7f5913e835278973e049315deecfd1f26a3af gst-plugins-base-1.16.0.tar.xz"