aboutsummaryrefslogtreecommitdiffstats
path: root/main/gst-plugins-ugly
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/gst-plugins-ugly
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
downloadaports-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.bz2
aports-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.xz
merged x11 repository into main
ref #255
Diffstat (limited to 'main/gst-plugins-ugly')
-rw-r--r--main/gst-plugins-ugly/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/main/gst-plugins-ugly/APKBUILD b/main/gst-plugins-ugly/APKBUILD
new file mode 100644
index 0000000000..cb49433c05
--- /dev/null
+++ b/main/gst-plugins-ugly/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-ugly
+pkgver=0.10.13
+pkgrel=0
+pkgdesc="GStreamer Multimedia Framework Ugly Plugins (gst-plugins-ugly)"
+url="http://gstreamer.freedesktop.org/"
+license="LGPL"
+depends= #"gstreamer0.10-ugly>=0.10.11 libdvdread>=4.1.3 lame>=3.98.2 libmpeg2>=0.5.1 a52dec>=0.7.4 libid3tag>=0.15.1b libmad>=0.15.1b libsidplay>=1.36.59 libcdio>=0.81"
+makedepends="pkgconfig lame-dev libmpeg2-dev a52dec-dev libid3tag-dev
+ libmad-dev glib-dev liboil-dev gstreamer-dev gst-plugins-base-dev"
+source="http://gstreamer.freedesktop.org//src/gst-plugins-ugly/gst-plugins-ugly-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-experimental \
+ --with-package-name="GStreamer Ugly Plugins (Alpine Linux)" \
+ --with-package-origin="http://www.alpinelinux.org/" || return 1
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="1619365247ef9cd7da1cd890285bf87a gst-plugins-ugly-0.10.13.tar.bz2"