aboutsummaryrefslogtreecommitdiffstats
path: root/main/gtk-doc
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-01 21:52:37 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-11-02 13:21:01 +0000
commit1f313fadf9f0ffa6779479d723a5ff776e85d320 (patch)
treeadf34b320e520463ff7ee80d831618604fc1bef7 /main/gtk-doc
parent9a81aed113da4576ff2f4dbe61e4031249afe00d (diff)
downloadaports-1f313fadf9f0ffa6779479d723a5ff776e85d320.tar.bz2
aports-1f313fadf9f0ffa6779479d723a5ff776e85d320.tar.xz
main/gtk-doc: fix build on ppc64le
Run autoreconf in prepare to fix build error in ppc64le. It was failing with error: /bin/bash: line 4: 101512 Segmentation fault itstool -m "${mo}" ${d}/C/index.docbook ${d}/C/fdl-appendix.xml
Diffstat (limited to 'main/gtk-doc')
-rw-r--r--main/gtk-doc/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/main/gtk-doc/APKBUILD b/main/gtk-doc/APKBUILD
index 76d6a4d79a..7932bc6130 100644
--- a/main/gtk-doc/APKBUILD
+++ b/main/gtk-doc/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gtk-doc
pkgver=1.26
-pkgrel=1
+pkgrel=2
pkgdesc="Documentation tool for public library API"
url="http://www.gtk.org/gtk-doc/"
arch="noarch"
license="GPL FDL"
depends="docbook-xsl gnome-doc-utils perl python2 py2-six pkgconf glib-dev highlight"
-makedepends="rarian-dev py-libxml2 gettext itstool"
+makedepends="rarian-dev py-libxml2 gettext itstool autoconf automake libtool"
checkdepends="bc"
source="https://download.gnome.org/sources/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz
0001-tests-Label-parts-with-decimals-not-roman-numerals.patch
@@ -17,6 +17,11 @@ source="https://download.gnome.org/sources/$pkgname/$pkgver/$pkgname-$pkgver.tar
options="!check"
builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$builddir"
+ autoreconf -vif
+}
+
build() {
cd "$builddir"
./configure \