aboutsummaryrefslogtreecommitdiffstats
path: root/main/gtk-doc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-10-09 16:50:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-10-09 16:50:09 +0000
commitfdffc7f115a0b11052e33fafed93a3b0c2bd94fd (patch)
tree61b8c3db92aaec35b5c6315bd4779632d0efddb8 /main/gtk-doc
parent7165ef184867cc9442f1bf96ba6cd78709d2311f (diff)
downloadaports-fdffc7f115a0b11052e33fafed93a3b0c2bd94fd.tar.bz2
aports-fdffc7f115a0b11052e33fafed93a3b0c2bd94fd.tar.xz
main/gtk-doc: fix depends and modernize
Diffstat (limited to 'main/gtk-doc')
-rw-r--r--main/gtk-doc/0001-tests-Label-parts-with-decimals-not-roman-numerals.patch76
-rw-r--r--main/gtk-doc/APKBUILD37
2 files changed, 98 insertions, 15 deletions
diff --git a/main/gtk-doc/0001-tests-Label-parts-with-decimals-not-roman-numerals.patch b/main/gtk-doc/0001-tests-Label-parts-with-decimals-not-roman-numerals.patch
new file mode 100644
index 0000000000..f53d261dbb
--- /dev/null
+++ b/main/gtk-doc/0001-tests-Label-parts-with-decimals-not-roman-numerals.patch
@@ -0,0 +1,76 @@
+From a8475278880270a3bf682d9552e26651081330ce Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Fri, 11 Aug 2017 21:19:28 +0200
+Subject: [PATCH] tests: Label parts with decimals, not roman numerals
+
+dblatex (via gtkdoc-mkpdf) warns that labels must be integers:
+
+ Warning: only an integer in @label can be processed: 'I'
+ Warning: only an integer in @label can be processed: 'II'
+ Warning: only an integer in @label can be processed: 'III'
+
+Make the labels decimal to placate dblatex. I'm not sure this is
+actually the best solution, though.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=786174
+---
+ tests/annotations/docs/tester-docs.xml | 4 ++--
+ tests/gobject/docs/tester-docs.xml | 6 +++---
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/tests/annotations/docs/tester-docs.xml b/tests/annotations/docs/tester-docs.xml
+index e2abf74..7d80f9d 100644
+--- a/tests/annotations/docs/tester-docs.xml
++++ b/tests/annotations/docs/tester-docs.xml
+@@ -16,7 +16,7 @@
+ </releaseinfo>
+ </bookinfo>
+
+- <reference label="II">
++ <reference label="2">
+ <title>API Reference</title>
+ <chapter id="main-api">
+ <title>Tests</title>
+@@ -24,7 +24,7 @@
+ </chapter>
+ </reference>
+
+- <part label="III">
++ <part label="3">
+ <title>Appendix</title>
+
+ <index id="api-index">
+diff --git a/tests/gobject/docs/tester-docs.xml b/tests/gobject/docs/tester-docs.xml
+index a534c55..05117ef 100644
+--- a/tests/gobject/docs/tester-docs.xml
++++ b/tests/gobject/docs/tester-docs.xml
+@@ -37,7 +37,7 @@
+ </para>
+ </preface>
+
+- <part label="I" id="part.i">
++ <part label="1" id="part.i">
+ <title>Overview</title>
+ <chapter id="Overview-building">
+ <title>How to build the library</title>
+@@ -45,7 +45,7 @@
+ </chapter>
+ </part>
+
+- <reference label="II" id="part.ii">
++ <reference label="2" id="part.ii">
+ <title>API Reference</title>
+ <chapter id="main-api">
+ <title>Tests</title>
+@@ -58,7 +58,7 @@
+ </chapter>
+ </reference>
+
+- <part label="III" id="part.iii">
++ <part label="3" id="part.iii">
+ <title>Appendix</title>
+
+ <chapter id="object-tree">
+--
+2.13.0
+
diff --git a/main/gtk-doc/APKBUILD b/main/gtk-doc/APKBUILD
index 0055c0e6f8..5e7a826500 100644
--- a/main/gtk-doc/APKBUILD
+++ b/main/gtk-doc/APKBUILD
@@ -1,34 +1,41 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gtk-doc
pkgver=1.26
-pkgrel=0
+pkgrel=1
pkgdesc="Documentation tool for public library API"
url="http://www.gtk.org/gtk-doc/"
arch="noarch"
license="GPL FDL"
-depends="docbook-xsl gnome-doc-utils perl pkgconfig python2"
+depends="docbook-xsl gnome-doc-utils perl python2 py2-six pkgconf glib-dev highlight"
makedepends="rarian-dev py-libxml2 gettext itstool"
-source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"
-
-_builddir="$srcdir/$pkgname-$pkgver"
-
-prepare() {
- cd "$_builddir"
-}
+checkdepends="bc"
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz
+ 0001-tests-Label-parts-with-decimals-not-roman-numerals.patch
+ "
+# it does not seem to be possible to disable tests of pdf which requires dblatex or fop
+# disable checks for now
+options="!check"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- || return 1
- make || return 1
+ --with-highlight=highlight
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-sha512sums="91f0e0e51d9f77794c0ab57bad5c2da242252f029ab2d4252f8740ccf8b18fed49a7f010f654f5ba60ebed74f7b65a5ef1f762c8661eebfcacfe15dc3bc3c52c gtk-doc-1.26.tar.xz"
+sha512sums="91f0e0e51d9f77794c0ab57bad5c2da242252f029ab2d4252f8740ccf8b18fed49a7f010f654f5ba60ebed74f7b65a5ef1f762c8661eebfcacfe15dc3bc3c52c gtk-doc-1.26.tar.xz
+a86438a9cbbf1bb60d2aea93f10a473f3fe7814cdbf0a454ff42bea88e79f21f9e748e063335aa6332878fa8f8a1c00ef288a44631b510471cc6bb806851b391 0001-tests-Label-parts-with-decimals-not-roman-numerals.patch"