aboutsummaryrefslogtreecommitdiffstats
path: root/main/help2man
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-11-21 08:12:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-11-21 08:12:28 +0000
commit0da12bdcbc1505aad074dc2aac61a87923893a43 (patch)
treed125ded756dc149e51c5b7f23ac3ef55d19797e6 /main/help2man
parent79687e3eedc156b29c4dcb1d4bb30314197ede5a (diff)
downloadaports-0da12bdcbc1505aad074dc2aac61a87923893a43.tar.bz2
aports-0da12bdcbc1505aad074dc2aac61a87923893a43.tar.xz
main/cgdb: upgrade to 0.6.8
Diffstat (limited to 'main/help2man')
-rw-r--r--main/help2man/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/main/help2man/APKBUILD b/main/help2man/APKBUILD
new file mode 100644
index 0000000000..c0041b006d
--- /dev/null
+++ b/main/help2man/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=help2man
+pkgver=1.46.4
+pkgrel=0
+pkgdesc="Create simple man pages from --help output"
+url="http://www.gnu.org/software/help2man"
+arch="noarch"
+license="GPLv3+"
+depends="perl"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="ftp://ftp.gnu.org/gnu/help2man/help2man-$pkgver.tar.xz"
+
+_builddir="$srcdir"/help2man-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="a1b7fe49eddae8a2537ed74ee9ef11cb help2man-1.46.4.tar.xz"
+sha256sums="1ae7f15f53b0cc55b070ae49df2ee5caa942c71529054e157599427bba3c5633 help2man-1.46.4.tar.xz"
+sha512sums="a573b16269c622a5fb25d170c2421fcd72f65faf6068b48f65ea03285e390b5d4e1e9f2f8567b9d92a7ff4ce95b4a7e4f06749c5cd994b6a24040693c7c7091b help2man-1.46.4.tar.xz"