aboutsummaryrefslogtreecommitdiffstats
path: root/main/hexchat
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-05-16 14:37:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-16 14:37:50 +0000
commit86c5cd4b68edc218f67c30c2a0e44fe2a6d12e35 (patch)
treea5a9e3a788bf0eecf2992f4dba4fee9ba65933a5 /main/hexchat
parent6cf63f3c0986dc7c118e36a4a439659ae43f759c (diff)
downloadaports-86c5cd4b68edc218f67c30c2a0e44fe2a6d12e35.tar.bz2
aports-86c5cd4b68edc218f67c30c2a0e44fe2a6d12e35.tar.xz
main/hexchat: fix build with lua
Diffstat (limited to 'main/hexchat')
-rw-r--r--main/hexchat/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/main/hexchat/APKBUILD b/main/hexchat/APKBUILD
index 89651e9e10..42c5cba186 100644
--- a/main/hexchat/APKBUILD
+++ b/main/hexchat/APKBUILD
@@ -8,7 +8,7 @@ arch="all"
license="GPL2+"
depends=""
makedepends="gtk+2.0-dev openssl-dev dbus-glib-dev perl-dev
- libsexy-dev python-dev libnotify-dev libproxy-dev
+ libsexy-dev python-dev libnotify-dev libproxy-dev lua5.3-dev
bash libtool autoconf automake"
install=""
subpackages="$pkgname-doc $pkgname-lang $pkgname-python:_python"
@@ -27,6 +27,7 @@ prepare() {
build() {
cd "$_builddir"
+ LUA=lua5.3 \
./configure --prefix=/usr \
--sysconfdir=/etc \
--enable-openssl \
@@ -34,9 +35,7 @@ build() {
--disable-textfe \
--disable-perl \
--enable-python \
- --enable-ipv6 \
- --enable-shm \
- --enable-spell=libsexy \
+ --enable-lua \
|| return 1
make || return 1
}