aboutsummaryrefslogtreecommitdiffstats
path: root/main/http-parser
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-05 02:28:18 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-05 02:29:03 +0100
commit91ecc291565acfd3993fa2312fa922fe905759eb (patch)
tree13f2b8addf7f2ef416463274f5c7a86a42eaba72 /main/http-parser
parentf1eab35e28df7454c2df3c7d348979db0b74f5f1 (diff)
downloadaports-91ecc291565acfd3993fa2312fa922fe905759eb.tar.bz2
aports-91ecc291565acfd3993fa2312fa922fe905759eb.tar.xz
main/http-parser: run tests in check phase
Diffstat (limited to 'main/http-parser')
-rw-r--r--main/http-parser/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/main/http-parser/APKBUILD b/main/http-parser/APKBUILD
index b09115bcae..38ed90d360 100644
--- a/main/http-parser/APKBUILD
+++ b/main/http-parser/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=http-parser
pkgver=2.7.1
-pkgrel=0
+pkgrel=1
pkgdesc="HTTP request/response parser for C"
url="https://github.com/nodejs/http-parser"
arch="all"
@@ -26,6 +26,11 @@ build() {
make library
}
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
cd "$builddir"
make install DESTDIR="$pkgdir" PREFIX="/usr"