aboutsummaryrefslogtreecommitdiffstats
path: root/main/hylafax
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-11-20 19:28:02 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-11-20 19:30:44 +0000
commitbfcd4f4ae56014b9d3fe6e80e1df399a80139be8 (patch)
treeaf6881eae275bc8e965516d4b80cec16220526e8 /main/hylafax
parent1ba89816e072203b9cf3804c33d38c766bd9659e (diff)
downloadaports-bfcd4f4ae56014b9d3fe6e80e1df399a80139be8.tar.bz2
aports-bfcd4f4ae56014b9d3fe6e80e1df399a80139be8.tar.xz
main/hylafax: add compattibility for libtiff 4.1
The configure script checks explicitly for libtiff versions. The version of libtiff that is currently in aports is 4.1, which was not included as a recognized version. Patch configure to recognize libtiff 4.1
Diffstat (limited to 'main/hylafax')
-rw-r--r--main/hylafax/APKBUILD10
-rw-r--r--main/hylafax/libtiff-41-compatibility.patch13
2 files changed, 19 insertions, 4 deletions
diff --git a/main/hylafax/APKBUILD b/main/hylafax/APKBUILD
index d2f73e139d..c32a64d0b0 100644
--- a/main/hylafax/APKBUILD
+++ b/main/hylafax/APKBUILD
@@ -2,19 +2,20 @@
# Maintainer: Cameron Banta <cbanta@gmail.com>
pkgname=hylafax
pkgver=6.0.7
-pkgrel=1
+pkgrel=2
pkgdesc="Sends and receives faxes"
url="http://www.hylafax.org/"
arch="all"
license="MIT"
#depends on gcc for libgcc_s.so, it's scripts are hardcoded to bash
depends="ghostscript bash tiff-tools"
-makedepends="zlib-dev tiff-dev gettext-dev"
+makedepends="zlib-dev tiff-dev<4.2 gettext-dev"
subpackages="$pkgname-doc $pkgname-lang"
source="ftp://ftp.hylafax.org/source/$pkgname-$pkgver.tar.gz
$pkgname.initd
$pkgname.confd
- hylafax-charset.patch"
+ hylafax-charset.patch
+ libtiff-41-compatibility.patch"
builddir="$srcdir"/$pkgname-$pkgver
# secfixes:
@@ -96,4 +97,5 @@ package(){
sha512sums="fc57feb416772a7a4bfaf5c3c76a0c2254ead2f63a72b3dfa465444327d440345a0402b7c7dad14f6d03029302ef39cf160c8ef5bfdee2c966fd15fbaac230a3 hylafax-6.0.7.tar.gz
3862cefcd26092000e4489c097537e5e0e2ae1f7c2a7a16b1e933b3bb78d136b6d8a65fb712ae245dd8ca881900408d0d9788bd2e0b859a9569fc6f4ede8cc7c hylafax.initd
3c07726cc9d7351dceb80a46354c6626e54b033b0f434c1db01db2a3b3ab5e9084d551dd23cae3ab40806f27aa5fa0a5b70c43a6b7802356871c0b343baa2376 hylafax.confd
-f97c805a62dfcb57f85f614b6eb28bd6b58e0582ce4f9aa5166337a46d453ea038a098223d879d120f51454008a5e8ed2fa60ba6e8be12af7b7d5a4927c51471 hylafax-charset.patch"
+f97c805a62dfcb57f85f614b6eb28bd6b58e0582ce4f9aa5166337a46d453ea038a098223d879d120f51454008a5e8ed2fa60ba6e8be12af7b7d5a4927c51471 hylafax-charset.patch
+ba4c2724e81e156fb603f22dc80fb25399d8661e1a2c176371d5ee36647e8c3710a3dfa3be97340aaba8631d8cee6c31c71829bd824cd6c4cd6239d947df0fcf libtiff-41-compatibility.patch"
diff --git a/main/hylafax/libtiff-41-compatibility.patch b/main/hylafax/libtiff-41-compatibility.patch
new file mode 100644
index 0000000000..72409ee1bf
--- /dev/null
+++ b/main/hylafax/libtiff-41-compatibility.patch
@@ -0,0 +1,13 @@
+diff --git a/configure b/configure.new
+index 8f591b554c..849e0ef355 100755
+--- a/configure
++++ b/configure.new
+@@ -2563,7 +2563,7 @@ EOF
+ tiff_offset_t="uint32"
+ tiff_bytecount_t="uint32"
+ ;;
+- 4.[0]) tiff_runlen_t="uint32"
++ 4.[01]) tiff_runlen_t="uint32"
+ tiff_offset_t="uint64"
+ tiff_bytecount_t="uint64"
+ echo '#define TIFFHeader TIFFHeaderClassic'