aboutsummaryrefslogtreecommitdiffstats
path: root/main/hylafaxplus/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-05-28 10:38:05 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-28 10:45:17 +0000
commit7f9789919af11d5fbb73e1e25596746dbfb3f159 (patch)
treeff413a62119a0a745afd538221afd164610ee2b5 /main/hylafaxplus/APKBUILD
parent61e4723a0317995acbe4262708693206e1906257 (diff)
downloadaports-7f9789919af11d5fbb73e1e25596746dbfb3f159.tar.bz2
aports-7f9789919af11d5fbb73e1e25596746dbfb3f159.tar.xz
main/hylafaxplus: moved from community.
This does not break anything on stable and I'm willing to maintain it for 2 years. According with #10495 I backport this to v3.8 and v3.9 too
Diffstat (limited to 'main/hylafaxplus/APKBUILD')
-rw-r--r--main/hylafaxplus/APKBUILD99
1 files changed, 99 insertions, 0 deletions
diff --git a/main/hylafaxplus/APKBUILD b/main/hylafaxplus/APKBUILD
new file mode 100644
index 0000000000..cd4b64e645
--- /dev/null
+++ b/main/hylafaxplus/APKBUILD
@@ -0,0 +1,99 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=hylafaxplus
+_pkgname=hylafax
+pkgver=7.0.0
+pkgrel=2
+pkgdesc="Making the Premier Open-Source Fax Management System Even Better"
+url="http://hylafax.sourceforge.net"
+arch="all"
+license="MIT"
+# check/test not supported from upstream
+options="!check"
+depends="ghostscript bash tiff-tools !$_pkgname"
+makedepends="zlib-dev tiff-dev gettext-dev openldap-dev lcms2-dev
+ libffi-dev jbig2dec-dev sed readline-dev"
+subpackages="$pkgname-doc $pkgname-lang $pkgname-openrc"
+source="https://downloads.sourceforge.net/hylafax/${_pkgname}-${pkgver}.tar.gz
+ $pkgname.initd
+ $pkgname.confd
+ common-functions-busybox-awk.patch
+ no-locale.patch
+ utf8-dictionary.patch
+ "
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ # the configure script does not handle ccache or distcc
+ export CC=gcc
+ export CXX=g++
+ ./configure \
+ --nointeractive \
+ --disable-pam \
+ --with-DIR_BIN=/usr/bin \
+ --with-DIR_SBIN=/usr/sbin \
+ --with-DIR_LIB=/usr/lib \
+ --with-DIR_LIBEXEC=/usr/sbin \
+ --with-DIR_LIBDATA=/var/spool/"$pkgname"/lib \
+ --with-DIR_LOCALE=/usr/share/locale/"$pkgname" \
+ --with-DIR_LOCKS=/var/lock \
+ --with-DIR_MAN=/usr/share/man \
+ --with-DIR_SPOOL=/var/spool/"$pkgname" \
+ --with-DIR_HTML=/usr/share/doc/"$pkgname"/html \
+ --with-PATH_IMPRIP="" \
+ --with-SYSVINIT=no \
+ --with-REGEX=yes \
+ --with-LIBTIFF="-ltiff -lz" \
+ --with-LIBINTL="-lintl" \
+ --with-DSO=auto \
+ --with-PATH_EGETTY=/bin/false \
+ --with-PATH_VGETTY=/bin/false
+
+ # parallel build breaks libfaxutil dso building
+ make -j1
+}
+
+package(){
+ cd "$builddir"
+ # this makefile has issues installing, it doesn't use the standard
+ # install - but the following seems to work
+ mkdir -p "${pkgdir}"/usr/bin "${pkgdir}"/usr/sbin
+ mkdir -p "${pkgdir}"/usr/lib/"$pkgname" "${pkgdir}"/usr/share/man
+ mkdir -p "${pkgdir}"/usr/share/locale/$pkgname
+ mkdir -p "${pkgdir}"/var/spool/"$pkgname"
+ mkdir -p "${pkgdir}"/var/spool/"$pkgname"/lib
+ touch "${pkgdir}"/var/spool/"$pkgname"/lib/pagesizes
+ chown uucp:uucp "${pkgdir}"/var/spool/"$pkgname"
+ chmod 0600 "${pkgdir}"/var/spool/"$pkgname"
+
+ make \
+ BIN="${pkgdir}/usr/bin" \
+ SBIN="${pkgdir}/usr/sbin" \
+ LIBDIR="${pkgdir}/usr/lib" \
+ LIB="${pkgdir}/usr/lib" \
+ LIBEXEC="${pkgdir}/usr/sbin" \
+ LIBDATA="${pkgdir}/var/spool/$pkgname"/lib \
+ MAN="${pkgdir}/usr/share/man" \
+ LOCALEDIR="${pkgdir}/usr/share/locale/$pkgname" \
+ SPOOL="${pkgdir}/var/spool/$pkgname" \
+ HTMLDIR="${pkgdir}/usr/share/doc/$pkgname/html" \
+ install
+
+ install -m644 -D "$srcdir/$_pkgname-$pkgver/COPYRIGHT" \
+ "$pkgdir"/usr/share/licenses/$pkgname/COPYRIGHT
+ install -m644 -D "$srcdir/$_pkgname-$pkgver/README" \
+ "$pkgdir"/usr/share/doc/$pkgname/README
+
+ install -D -m755 "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname
+ install -D -m644 "$srcdir"/$pkgname.confd \
+ "$pkgdir"/etc/conf.d/$pkgname
+}
+
+sha512sums="c63fdbff79c2ced29e03907c2e401c95a739e343414840a25b9582e3f4db880eaf4622295035e4728a9d1f224f97985007944397f28c9b29595aeec157bc2031 hylafax-7.0.0.tar.gz
+54025c3ee3683476fa947f1e29cda7cc61027e2cbb0be1d400c7f715b4087a5c7693e0e3f8fdb1a8ecf56f48c03e4f0d82d12a2d6ae93707b13d08569510c917 hylafaxplus.initd
+a2117eddc8f0ff70a23a90f2001dcb88c5bddee46ffa021d6d1701cc5cfc3bcb0362ead2b1b1ce2b288992728053c5947466d08916649f45e7dfb1876576e50f hylafaxplus.confd
+41ae2055a7781d83fc275aafe18ced0fe75ba79d3ad7d5096eabaeae3a514b564723185dd33820268577174f6c53bfcfddb30922ba50754b15c5c3b0abbec837 common-functions-busybox-awk.patch
+4a1243daff9904e6395c3e28aa4a78a74de99f5aa9dbf5055a3781acfcd9b1b3db42b1569409b27e3ef9b0e55272dc99122436a79a08c9a1c140c2547c5a2c15 no-locale.patch
+f5f1e33897a91b8297311c033d50e7ea2f9088568264a5b9224285066a504da8cc4296f973dd0a70e09abca538cef26964c6181f4f67f76400783d0697f05e61 utf8-dictionary.patch"