aboutsummaryrefslogtreecommitdiffstats
path: root/main/icecast
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-14 13:45:41 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-09 13:13:25 +0000
commit5731e2dde4119947605b840093bc4257a49893fa (patch)
tree04b02df86bd913b9d69c18c8e5480a9a755e034b /main/icecast
parent919a7023941a246c06457d0912bf7748a8b19b06 (diff)
downloadaports-5731e2dde4119947605b840093bc4257a49893fa.tar.bz2
aports-5731e2dde4119947605b840093bc4257a49893fa.tar.xz
main/icecast: modernize abuild
Diffstat (limited to 'main/icecast')
-rw-r--r--main/icecast/APKBUILD21
1 files changed, 4 insertions, 17 deletions
diff --git a/main/icecast/APKBUILD b/main/icecast/APKBUILD
index f61694f311..b6007591ba 100644
--- a/main/icecast/APKBUILD
+++ b/main/icecast/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Open source media server"
url="http://www.icecast.org"
arch="all"
license="GPL"
-depends=
+depends=""
install="$pkgname.pre-install"
pkgusers="icecast"
pkggroups="icecast"
@@ -18,14 +18,9 @@ source="http://downloads.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
icecast.initd
icecast.confd"
-prepare() {
- cd "$srcdir"/$pkgname-$pkgver
- patch -p1 -i "$srcdir"/conf-change-owner.patch
-}
-
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$srcdir"/$pkgname-$pkgver
-
+ cd $builddir
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -41,21 +36,13 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd $builddir
make DESTDIR="$pkgdir" install
install -D -m755 ../icecast.initd "$pkgdir"/etc/init.d/icecast
install -D -m755 ../icecast.confd "$pkgdir"/etc/conf.d/icecast
install -d -D -o icecast -g icecast "$pkgdir"/var/log/icecast
}
-md5sums="83d7d34dbe22f0f8fc119d2c9839efc0 icecast-2.4.3.tar.gz
-d65fe756a3811e21fd8327ec599206c8 conf-change-owner.patch
-a868f60a4bf32716a0e8de46f3f9c876 icecast.initd
-37ceeb26f61551e712364a2dffa8c208 icecast.confd"
-sha256sums="c85ca48c765d61007573ee1406a797ae6cb31fb5961a42e7f1c87adb45ddc592 icecast-2.4.3.tar.gz
-52a85e356192f805a02c6e00375d8a9ebfda8112d9458b19eb183e238d7e54d3 conf-change-owner.patch
-6c997c6dbc8bc3c3d2debec6f410983fd6a52465d8c3a2e2ca4a45be8a68d254 icecast.initd
-bf0b7596f642cf920f7909af28d7bb632f5616fee8b3c44decd609ab748e164a icecast.confd"
sha512sums="70e755ee935e738f2b7310333823992517747897692d101b67d73d5cd40d6385a20c25d089a0430806c116021e6e2055761efee9fec27cd9bccb2b58a2bfd446 icecast-2.4.3.tar.gz
3de3ed881a60f99d3e4cf656a46cdb157e95abcfa9bd44ebc7e13840a9b0ee84ec9e5b30878d67e42385dac5fa974694c215ad162b910c47b6b7864d474bf636 conf-change-owner.patch
c78f7e6aa9ff04f7400944e95485994a23493e79d47e0b9799b9235fa5f3ed9d64840be1380a262c30594f9fa2dac96d904226608bfc133d51b3a62ed90d990d icecast.initd