aboutsummaryrefslogtreecommitdiffstats
path: root/main/imagemagick
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-09-25 14:35:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-26 14:49:27 +0000
commit5e77c6cf0166675c2f293fb6b2dfb53a025793eb (patch)
tree779025c39766dadd4043023503b6deb5b9fcd382 /main/imagemagick
parent95801497ec61bb8369976da2b8ae6640b7e929e4 (diff)
downloadaports-5e77c6cf0166675c2f293fb6b2dfb53a025793eb.tar.bz2
aports-5e77c6cf0166675c2f293fb6b2dfb53a025793eb.tar.xz
main/imagemagick: upgrade to 7.0.7.4, modernize, threads, webp and rsvg
upgrade to 7.0.7.4 and modernize enable threads, webp and rsvg support while at it
Diffstat (limited to 'main/imagemagick')
-rw-r--r--main/imagemagick/APKBUILD33
1 files changed, 20 insertions, 13 deletions
diff --git a/main/imagemagick/APKBUILD b/main/imagemagick/APKBUILD
index ee44e478fe..624bc6cca9 100644
--- a/main/imagemagick/APKBUILD
+++ b/main/imagemagick/APKBUILD
@@ -2,10 +2,10 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=imagemagick
-pkgver=7.0.7.3
+pkgver=7.0.7.4
_abiver=7
_pkgver=${pkgver%.*}-${pkgver##*.}
-pkgrel=1
+pkgrel=0
pkgdesc="A collection of tools and libraries for many image formats"
url="http://www.imagemagick.org/"
arch="all"
@@ -13,8 +13,9 @@ license="custom"
depends=""
options="libtool"
makedepends="zlib-dev libpng-dev libjpeg-turbo-dev freetype-dev fontconfig-dev
- perl-dev ghostscript-dev libwebp-dev libtool tiff-dev lcms2-dev libxml2-dev"
-subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx"
+ perl-dev ghostscript-dev libwebp-dev libtool tiff-dev lcms2-dev
+ libwebp-dev libxml2-dev librsvg-dev"
+subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx $pkgname-libs"
source="http://www.imagemagick.org/download/releases/ImageMagick-$_pkgver.tar.xz"
builddir="$srcdir/ImageMagick-${_pkgver}"
@@ -24,7 +25,7 @@ build() {
# fix doc dir, Gentoo bug 91911
sed -i -e \
's:DOCUMENTATION_PATH="${DATA_DIR}/doc/${DOCUMENTATION_RELATIVE_PATH}":DOCUMENTATION_PATH="/usr/share/doc/imagemagick":g' \
- configure || die
+ configure
./configure \
--build=$CBUILD \
@@ -33,31 +34,37 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --without-threads \
+ --disable-static \
+ --with-threads \
--without-x \
--with-tiff \
- --with-lcms2 \
+ --with-png \
+ --with-webp \
+ --with-rsvg \
--with-gslib \
--with-gs-font-dir=/usr/share/fonts/Type1 \
--with-modules \
--with-xml \
- $_pic \
- || return 1
- make || return 1
+ $_pic
+ make
}
package() {
cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ make -j1 DESTDIR="$pkgdir" install
if ! [ -e "$pkgdir"/usr/lib/libMagickCore-$_abiver.Q16HDRI.so ]; then
error "Has ABI verision changed? (current is $_abiver)"
return 1
fi
+ # we cannot let abuild delete the *.la files due to we need *.la
+ # for the modules
+ rm "$pkgdir"/usr/lib/*.la
+
find "$pkgdir" -name '.packlist' -o -name 'perllocal.pod' \
-o -name '*.bs' -delete
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE || return 1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
_cxx() {
@@ -66,4 +73,4 @@ _cxx() {
mv "$pkgdir"/usr/lib/libMagick++*.so.* "$subpkgdir"/usr/lib/
}
-sha512sums="6c7099e4f2a6ba66c330733d33e1241e34562f6c4154ff1eb2e0fd051824478001d7556d10a5aa5648a94d44ade7cd6db11b3d5ee67ffb978ee8c7616d87d135 ImageMagick-7.0.7-3.tar.xz"
+sha512sums="80942510d8daed872997175dc63bd8a27839f2adfb5da01f74618fbcf4a137be3ad868c7448158e539640df114c2066aa02d4f57d76215b7db3ab8c234d86129 ImageMagick-7.0.7-4.tar.xz"