aboutsummaryrefslogtreecommitdiffstats
path: root/main/inotify-tools
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-01-04 13:39:39 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-01-04 13:40:15 +0000
commit1093db0e0e8453cd2934f6d3dad816477faba55b (patch)
tree652433cf7f6a42302d0debb29042615ebc5d5daa /main/inotify-tools
parent0bf208616040e2eef406a59c7f39b63e69e3f2c0 (diff)
downloadaports-1093db0e0e8453cd2934f6d3dad816477faba55b.tar.bz2
aports-1093db0e0e8453cd2934f6d3dad816477faba55b.tar.xz
main/inotify-tools: upgrade to 3.20.0, modernize APKBUILD
Diffstat (limited to 'main/inotify-tools')
-rw-r--r--main/inotify-tools/APKBUILD25
-rw-r--r--main/inotify-tools/correct-code-alignment.patch46
2 files changed, 59 insertions, 12 deletions
diff --git a/main/inotify-tools/APKBUILD b/main/inotify-tools/APKBUILD
index d360ef995d..bf850c78e6 100644
--- a/main/inotify-tools/APKBUILD
+++ b/main/inotify-tools/APKBUILD
@@ -1,8 +1,8 @@
# Contributor:
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname="inotify-tools"
-pkgver=3.14
-pkgrel=2
+pkgver=3.20.0
+pkgrel=0
pkgdesc="C library and CLI tools providing a simple interface to inotify"
url="https://github.com/rvoicilas/inotify-tools"
arch="all"
@@ -10,27 +10,28 @@ license="GPL-2.0"
depends="!inotify-tools-inc"
makedepends="automake autoconf libtool"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/downloads/rvoicilas/$pkgname/$pkgname-$pkgver.tar.gz"
-
+source="$pkgname-$pkgver.tar.gz::https://github.com/rvoicilas/$pkgname/archive/$pkgver.tar.gz
+ correct-code-alignment.patch"
builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
build() {
cd "$builddir"
- autoreconf -vif || return 1
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info \
- || return 1
- make || return 1
+ --infodir=/usr/share/info
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-md5sums="b43d95a0fa8c45f8bab3aec9672cf30c inotify-tools-3.14.tar.gz"
-sha256sums="222bcca8893d7bf8a1ce207fb39ceead5233b5015623d099392e95197676c92f inotify-tools-3.14.tar.gz"
-sha512sums="6074d510e89bba5da0d7c4d86f2562c662868666ba0a7ea5d73e53c010a0050dd1fc01959b22cffdb9b8a35bd1b0b43c04d02d6f19927520f05889e8a9297dfb inotify-tools-3.14.tar.gz"
+sha512sums="a06b2cd92e1aec2a01fd45a48be442fcf613aec11f17dff123d49d94904394230cb2ca810640180eced8dfe8a5bd76d89226a10f65c3a6e85528b10a24f79e1d inotify-tools-3.20.0.tar.gz
+5beb28357c2555961002a12b8ca33b0fdb4e9ce374ad5802c5f98d8fdaca8686a52a4ceb50100e50fca2813c8be0b8e9929168391bf805cb276f8d457bad1ba9 correct-code-alignment.patch"
diff --git a/main/inotify-tools/correct-code-alignment.patch b/main/inotify-tools/correct-code-alignment.patch
new file mode 100644
index 0000000000..5bae5c772a
--- /dev/null
+++ b/main/inotify-tools/correct-code-alignment.patch
@@ -0,0 +1,46 @@
+From 5fe3ba82134d8b85adc69cf1d6c5742b4bde20b4 Mon Sep 17 00:00:00 2001
+From: James Knight <james.d.knight@live.com>
+Date: Thu, 16 Jun 2016 00:00:57 -0400
+Subject: [PATCH] correct code alignment
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The following replaces the indented section of code from spaces to tabs.
+No functional changes. Aside from consistency, this resolves a GCC 6
+build issue with the flag `-Werror=misleading-indentation` enabled:
+
+ inotifywait.c: In function ‘output_event_csv’:
+ inotifywait.c:126:5: error: this ‘if’ clause does not guard...
+ [-Werror=misleading-indentation]
+ if (filename != NULL)
+ ^~
+ inotifywait.c:129:2: note: ...this statement, but the latter is
+ misleadingly indented as if it is guarded
+ by the ‘if’
+ printf("%s,", csv_escape( inotifytools_event_to_str( event->mask )
+ ) );
+ ^~~~~~
+
+Signed-off-by: James Knight <james.d.knight@live.com>
+---
+ src/inotifywait.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/inotifywait.c b/src/inotifywait.c
+index c5ce5e3..404a85b 100644
+--- a/src/inotifywait.c
++++ b/src/inotifywait.c
+@@ -122,9 +122,9 @@ void validate_format( char * fmt ) {
+
+
+ void output_event_csv( struct inotify_event * event ) {
+- char *filename = csv_escape(inotifytools_filename_from_wd(event->wd));
+- if (filename != NULL)
+- printf("%s,", filename);
++ char *filename = csv_escape(inotifytools_filename_from_wd(event->wd));
++ if (filename != NULL)
++ printf("%s,", filename);
+
+ printf("%s,", csv_escape( inotifytools_event_to_str( event->mask ) ) );
+ if ( event->len > 0 )