aboutsummaryrefslogtreecommitdiffstats
path: root/main/inotify-tools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-11-01 14:52:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-01 14:53:15 +0000
commit73087349feee21e183118864dda25078ef41489e (patch)
tree1bfb02c08483240cd95ed536e840ba07fd521c91 /main/inotify-tools
parent0f05b5771bb51bf5df68817f1976abfbe8a80523 (diff)
downloadaports-73087349feee21e183118864dda25078ef41489e.tar.bz2
aports-73087349feee21e183118864dda25078ef41489e.tar.xz
main/inotify-tools: moved from testing
Diffstat (limited to 'main/inotify-tools')
-rw-r--r--main/inotify-tools/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/inotify-tools/APKBUILD b/main/inotify-tools/APKBUILD
new file mode 100644
index 0000000000..5a06822c78
--- /dev/null
+++ b/main/inotify-tools/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor:
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname="inotify-tools"
+pkgver=3.14
+pkgrel=1
+pkgdesc="C library and CLI tools providing a simple interface to inotify"
+url="http://github.com/rvoicilas/inotify-tools"
+arch="all"
+license="GPL2"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/downloads/rvoicilas/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+ return 0
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/*.la || return 1
+}
+
+md5sums="b43d95a0fa8c45f8bab3aec9672cf30c inotify-tools-3.14.tar.gz"
+sha256sums="222bcca8893d7bf8a1ce207fb39ceead5233b5015623d099392e95197676c92f inotify-tools-3.14.tar.gz"
+sha512sums="6074d510e89bba5da0d7c4d86f2562c662868666ba0a7ea5d73e53c010a0050dd1fc01959b22cffdb9b8a35bd1b0b43c04d02d6f19927520f05889e8a9297dfb inotify-tools-3.14.tar.gz"