aboutsummaryrefslogtreecommitdiffstats
path: root/main/inotify-tools
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-01-08 14:36:09 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-01-08 14:36:09 +0000
commit9a7e1a495186614a8c917a569896128ddbb8fb6c (patch)
tree8ceeb04f0c6ee7f1200e6e978134450f5aae97aa /main/inotify-tools
parent052f95041c6d740b41b8806ef527de116b9bb541 (diff)
downloadaports-9a7e1a495186614a8c917a569896128ddbb8fb6c.tar.bz2
aports-9a7e1a495186614a8c917a569896128ddbb8fb6c.tar.xz
main/inotify-tools: upgrade to 3.20.1
Diffstat (limited to 'main/inotify-tools')
-rw-r--r--main/inotify-tools/APKBUILD8
-rw-r--r--main/inotify-tools/correct-code-alignment.patch46
2 files changed, 3 insertions, 51 deletions
diff --git a/main/inotify-tools/APKBUILD b/main/inotify-tools/APKBUILD
index bf850c78e6..dd055b5d69 100644
--- a/main/inotify-tools/APKBUILD
+++ b/main/inotify-tools/APKBUILD
@@ -1,7 +1,7 @@
# Contributor:
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname="inotify-tools"
-pkgver=3.20.0
+pkgver=3.20.1
pkgrel=0
pkgdesc="C library and CLI tools providing a simple interface to inotify"
url="https://github.com/rvoicilas/inotify-tools"
@@ -10,8 +10,7 @@ license="GPL-2.0"
depends="!inotify-tools-inc"
makedepends="automake autoconf libtool"
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/rvoicilas/$pkgname/archive/$pkgver.tar.gz
- correct-code-alignment.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rvoicilas/$pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -33,5 +32,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="a06b2cd92e1aec2a01fd45a48be442fcf613aec11f17dff123d49d94904394230cb2ca810640180eced8dfe8a5bd76d89226a10f65c3a6e85528b10a24f79e1d inotify-tools-3.20.0.tar.gz
-5beb28357c2555961002a12b8ca33b0fdb4e9ce374ad5802c5f98d8fdaca8686a52a4ceb50100e50fca2813c8be0b8e9929168391bf805cb276f8d457bad1ba9 correct-code-alignment.patch"
+sha512sums="a97d27e6033036f0db5c0737bee3510206db9f4c843f0d18f1b2e179e838624ea33316c34fd9917c158dbb3580367908e90042fb1bfb146f150c32833b0b2ff2 inotify-tools-3.20.1.tar.gz"
diff --git a/main/inotify-tools/correct-code-alignment.patch b/main/inotify-tools/correct-code-alignment.patch
deleted file mode 100644
index 5bae5c772a..0000000000
--- a/main/inotify-tools/correct-code-alignment.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 5fe3ba82134d8b85adc69cf1d6c5742b4bde20b4 Mon Sep 17 00:00:00 2001
-From: James Knight <james.d.knight@live.com>
-Date: Thu, 16 Jun 2016 00:00:57 -0400
-Subject: [PATCH] correct code alignment
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-The following replaces the indented section of code from spaces to tabs.
-No functional changes. Aside from consistency, this resolves a GCC 6
-build issue with the flag `-Werror=misleading-indentation` enabled:
-
- inotifywait.c: In function ‘output_event_csv’:
- inotifywait.c:126:5: error: this ‘if’ clause does not guard...
- [-Werror=misleading-indentation]
- if (filename != NULL)
- ^~
- inotifywait.c:129:2: note: ...this statement, but the latter is
- misleadingly indented as if it is guarded
- by the ‘if’
- printf("%s,", csv_escape( inotifytools_event_to_str( event->mask )
- ) );
- ^~~~~~
-
-Signed-off-by: James Knight <james.d.knight@live.com>
----
- src/inotifywait.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/inotifywait.c b/src/inotifywait.c
-index c5ce5e3..404a85b 100644
---- a/src/inotifywait.c
-+++ b/src/inotifywait.c
-@@ -122,9 +122,9 @@ void validate_format( char * fmt ) {
-
-
- void output_event_csv( struct inotify_event * event ) {
-- char *filename = csv_escape(inotifytools_filename_from_wd(event->wd));
-- if (filename != NULL)
-- printf("%s,", filename);
-+ char *filename = csv_escape(inotifytools_filename_from_wd(event->wd));
-+ if (filename != NULL)
-+ printf("%s,", filename);
-
- printf("%s,", csv_escape( inotifytools_event_to_str( event->mask ) ) );
- if ( event->len > 0 )