aboutsummaryrefslogtreecommitdiffstats
path: root/main/iproute2/fix-install-errors.patch
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-06-27 23:03:10 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-06-27 23:04:11 +0200
commitf4ec0f7bd20cccc3b274f5aed1a3fd634987efe7 (patch)
tree7df679a25aaaa40910acbb09c2ca8fd51a184ac3 /main/iproute2/fix-install-errors.patch
parented3867ce17f2c5612da25f237d247e3d563e3c36 (diff)
downloadaports-f4ec0f7bd20cccc3b274f5aed1a3fd634987efe7.tar.bz2
aports-f4ec0f7bd20cccc3b274f5aed1a3fd634987efe7.tar.xz
main/iproute2: fix install(1) invocation if libmnl isn't available
Diffstat (limited to 'main/iproute2/fix-install-errors.patch')
-rw-r--r--main/iproute2/fix-install-errors.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/main/iproute2/fix-install-errors.patch b/main/iproute2/fix-install-errors.patch
new file mode 100644
index 0000000000..d514032b77
--- /dev/null
+++ b/main/iproute2/fix-install-errors.patch
@@ -0,0 +1,40 @@
+Without this patch the following error message shows up three times
+during `make install:`
+
+ install -m 0755 /home/travis/build/alpinelinux/aports/main/iproute2/pkg/iproute2/sbin
+ BusyBox v1.28.4 (2018-05-30 10:45:57 UTC) multi-call binary.
+ Usage: install [-cdDsp] [-o USER] [-g GRP] [-m MODE] [-t DIR] [SOURCE]... DEST
+ Copy files and set attributes
+ -c Just copy (default)
+ -d Create directories
+ -D Create leading target directories
+ -s Strip symbol table
+ -p Preserve date
+ -o USER Set ownership
+ -g GRP Set group ownership
+ -m MODE Set permissions
+ -t DIR Install to DIR
+ make[1]: *** [Makefile:25: install] Error 1
+
+diff -upr iproute2-4.17.0.orig/Makefile iproute2-4.17.0/Makefile
+--- iproute2-4.17.0.orig/Makefile 2018-06-27 22:58:35.818077991 +0200
++++ iproute2-4.17.0/Makefile 2018-06-27 23:00:33.118560603 +0200
+@@ -61,7 +61,17 @@ WFLAGS += -Wmissing-declarations -Wold-s
+ CFLAGS := $(WFLAGS) $(CCOPTS) -I../include -I../include/uapi $(DEFINES) $(CFLAGS)
+ YACCFLAGS = -d -t -v
+
+-SUBDIRS=lib ip tc bridge misc netem genl tipc devlink rdma man
++SUBDIRS=lib ip tc bridge misc netem genl man
++
++# The following subdirs require libmnl. If libmnl isn't installed
++# install(1) is called with invalid arguments when the install
++# target is invoked in those subdirs because $(TARGETS) is empty.
++#
++# To prevent these errors we only include the subdirs if libmnl is
++# actually available.
++ifeq ($(HAVE_MNL),y)
++SUBDIRS += tipc devlink rdma
++endif
+
+ LIBNETLINK=../lib/libutil.a ../lib/libnetlink.a
+ LDLIBS += $(LIBNETLINK)