aboutsummaryrefslogtreecommitdiffstats
path: root/main/iproute2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-10-02 08:56:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-02 08:56:40 +0000
commit04ac08239caa46c11154c0d14dad48755a5fc8fc (patch)
treef5435c0a77971cc755aa9549b2c12697d1a3086f /main/iproute2
parent9d5fcef7cd33bb97274c7b1363425e36d524892a (diff)
downloadaports-04ac08239caa46c11154c0d14dad48755a5fc8fc.tar.bz2
aports-04ac08239caa46c11154c0d14dad48755a5fc8fc.tar.xz
main/iproute2: upgrade to 3.15.0
Diffstat (limited to 'main/iproute2')
-rw-r--r--main/iproute2/0001-iproute2-various-header-include-fixes-for-compiling-.patch110
-rw-r--r--main/iproute2/APKBUILD12
2 files changed, 4 insertions, 118 deletions
diff --git a/main/iproute2/0001-iproute2-various-header-include-fixes-for-compiling-.patch b/main/iproute2/0001-iproute2-various-header-include-fixes-for-compiling-.patch
deleted file mode 100644
index d8b36dcc97..0000000000
--- a/main/iproute2/0001-iproute2-various-header-include-fixes-for-compiling-.patch
+++ /dev/null
@@ -1,110 +0,0 @@
-From 9bf5b7a91b67ac47a00c1ed2ccd959ebfba4fb48 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Tue, 27 May 2014 07:16:04 +0000
-Subject: [PATCH] iproute2: various header include fixes for compiling with
- musl libc
-
-We need limits.h for LONG_MIN and LONG_MAX, sys/param.h for MIN and
-sys/select for struct timeval.
-
-This fixes the following compile errors with musl libc:
-
-f_bpf.c: In function 'bpf_parse_opt':
-f_bpf.c:181:12: error: 'LONG_MIN' undeclared (first use in this function)
- if (h == LONG_MIN || h == LONG_MAX) {
- ^
-...
-
-tc_util.o: In function `print_tcstats2_attr':
-tc_util.c:(.text+0x13fe): undefined reference to `MIN'
-tc_util.c:(.text+0x1465): undefined reference to `MIN'
-tc_util.c:(.text+0x14ce): undefined reference to `MIN'
-tc_util.c:(.text+0x154c): undefined reference to `MIN'
-tc_util.c:(.text+0x160a): undefined reference to `MIN'
-tc_util.o:tc_util.c:(.text+0x174e): more undefined references to `MIN' follow
-...
-
-tc_stab.o: In function `print_size_table':
-tc_stab.c:(.text+0x40f): undefined reference to `MIN'
-...
-
-fdb.c:247:30: error: 'ULONG_MAX' undeclared (first use in this function)
- (vni >> 24) || vni == ULONG_MAX)
- ^
-
-lnstat.h:28:17: error: field 'last_read' has incomplete type
- struct timeval last_read; /* last time of read */
- ^
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- bridge/fdb.c | 1 +
- misc/lnstat.h | 1 +
- tc/f_bpf.c | 1 +
- tc/tc_stab.c | 1 +
- tc/tc_util.c | 1 +
- 5 files changed, 5 insertions(+)
-
-diff --git a/bridge/fdb.c b/bridge/fdb.c
-index 9b720e3..336cf9d 100644
---- a/bridge/fdb.c
-+++ b/bridge/fdb.c
-@@ -20,6 +20,7 @@
- #include <linux/if_ether.h>
- #include <linux/neighbour.h>
- #include <string.h>
-+#include <limits.h>
-
- #include "libnetlink.h"
- #include "br_common.h"
-diff --git a/misc/lnstat.h b/misc/lnstat.h
-index 06774ab..83dad97 100644
---- a/misc/lnstat.h
-+++ b/misc/lnstat.h
-@@ -2,6 +2,7 @@
- #define _LNSTAT_H
-
- #include <limits.h>
-+#include <sys/select.h>
-
- #define LNSTAT_VERSION "0.02 041002"
-
-diff --git a/tc/f_bpf.c b/tc/f_bpf.c
-index d52d7d8..8f1593c 100644
---- a/tc/f_bpf.c
-+++ b/tc/f_bpf.c
-@@ -20,6 +20,7 @@
- #include <string.h>
- #include <stdbool.h>
- #include <errno.h>
-+#include <limits.h>
- #include <linux/filter.h>
- #include <linux/if.h>
-
-diff --git a/tc/tc_stab.c b/tc/tc_stab.c
-index 47b4e5e..a8404f8 100644
---- a/tc/tc_stab.c
-+++ b/tc/tc_stab.c
-@@ -17,6 +17,7 @@
- #include <fcntl.h>
- #include <math.h>
- #include <sys/socket.h>
-+#include <sys/param.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
- #include <string.h>
-diff --git a/tc/tc_util.c b/tc/tc_util.c
-index 15fb053..f1fca0a 100644
---- a/tc/tc_util.c
-+++ b/tc/tc_util.c
-@@ -16,6 +16,7 @@
- #include <syslog.h>
- #include <fcntl.h>
- #include <sys/socket.h>
-+#include <sys/param.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
- #include <string.h>
---
-1.9.3
-
diff --git a/main/iproute2/APKBUILD b/main/iproute2/APKBUILD
index 9b474f2f86..ef7d64cab4 100644
--- a/main/iproute2/APKBUILD
+++ b/main/iproute2/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iproute2
-pkgver=3.14.0
+pkgver=3.15.0
_realver=$pkgver
pkgrel=0
pkgdesc="IP Routing Utilities"
@@ -12,7 +12,6 @@ install="$pkgname.post-install"
makedepends="bison flex bash iptables-dev"
subpackages="$pkgname-doc"
source="http://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz
- 0001-iproute2-various-header-include-fixes-for-compiling-.patch
"
prepare() {
@@ -44,9 +43,6 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
-md5sums="bd9d7567bbb987c88120669f5e1a1092 iproute2-3.14.0.tar.xz
-b3ea32f3ea905949ed5d53d08c6d1b48 0001-iproute2-various-header-include-fixes-for-compiling-.patch"
-sha256sums="bda38951c49f89ffc2e2fe85579ce616337b5d3a2f0319921fd071c838356bd4 iproute2-3.14.0.tar.xz
-e10d5be14f1b37a9ca9b7f024c3858fbece46a350d9c1268d1708754aa3eaa48 0001-iproute2-various-header-include-fixes-for-compiling-.patch"
-sha512sums="774ab15bc0001d79884d9c88920c63dead162f6d93816bb921beca3b5bcc12555b07beaa726107491b5a6c7eae89558dc1dba85712d0fb35c3a78133356b2921 iproute2-3.14.0.tar.xz
-8d3e1d905278a6b4bb60ca4f76ce09268e237fcd410e193c3049f54816037fc4d396b61addc34beea5b5a2ffece4605903e28c078d67168eefb5cabd1d7afa0a 0001-iproute2-various-header-include-fixes-for-compiling-.patch"
+md5sums="5b1711c9d16071959052e369a2682d77 iproute2-3.15.0.tar.xz"
+sha256sums="5359ed1f31839d8542a057c0c4233131ab9c28d8c41fc9c8484579d9c0b99af4 iproute2-3.15.0.tar.xz"
+sha512sums="392b29c25df8a588d78afb7f827a41091d45c1c0fa95d10b39d8f381bba5ee8a7373fa58d09ff36c8dfe84ab752a7111ddfeef7e2bf0fbfe11adf35a13adb87f iproute2-3.15.0.tar.xz"