aboutsummaryrefslogtreecommitdiffstats
path: root/main/iproute2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-03-22 09:19:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-03-22 09:19:16 +0000
commit44c3a035be2c788273cb5c2e43f73cabaf2cac22 (patch)
tree5c0a0086feaf91c8a169b490c4864af56299f0da /main/iproute2
parentc9f07547a4942c979145c47daa0f2ec76ce4c722 (diff)
downloadaports-44c3a035be2c788273cb5c2e43f73cabaf2cac22.tar.bz2
aports-44c3a035be2c788273cb5c2e43f73cabaf2cac22.tar.xz
main/iproute2: upgrade to 3.2.0
Diffstat (limited to 'main/iproute2')
-rw-r--r--main/iproute2/APKBUILD12
-rw-r--r--main/iproute2/remove-libnl-headers.patch31
2 files changed, 38 insertions, 5 deletions
diff --git a/main/iproute2/APKBUILD b/main/iproute2/APKBUILD
index 5940545e84..11bb97a941 100644
--- a/main/iproute2/APKBUILD
+++ b/main/iproute2/APKBUILD
@@ -1,17 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iproute2
-pkgver=2.6.38
+pkgver=3.2.0
_realver=$pkgver
-pkgrel=1
+pkgrel=0
pkgdesc="IP Routing Utilities"
-url="http://www.linux-foundation.org/en/Net:Iproute2"
+url="http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2"
arch="all"
license="GPL2"
depends=
install="$pkgname.post-install"
makedepends="bison flex bash"
subpackages="$pkgname-doc"
-source="http://devresources.linux-foundation.org/dev/iproute2/download/$pkgname-$_realver.tar.bz2
+source="http://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz
+ remove-libnl-headers.patch
"
prepare() {
@@ -39,4 +40,5 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
-md5sums="a243bfea837e71824b7ca26c3bb45fa8 iproute2-2.6.38.tar.bz2"
+md5sums="6f814291cc3d7f4312cf8c2c052da5f1 iproute2-3.2.0.tar.xz
+63c85514579652f7912f240234d6d4b4 remove-libnl-headers.patch"
diff --git a/main/iproute2/remove-libnl-headers.patch b/main/iproute2/remove-libnl-headers.patch
new file mode 100644
index 0000000000..921e1fa82e
--- /dev/null
+++ b/main/iproute2/remove-libnl-headers.patch
@@ -0,0 +1,31 @@
+From 13603f6a9e46f08576f6284a0ef1ce1fbf94ffe0 Mon Sep 17 00:00:00 2001
+From: Stephen Hemminger <shemminger@vyatta.com>
+Date: Tue, 10 Jan 2012 08:50:49 -0800
+Subject: [PATCH] iplt2p: remove unused libnl headers
+
+Leftover from change to original code.
+---
+ ip/ipl2tp.c | 7 -------
+ 1 files changed, 0 insertions(+), 7 deletions(-)
+
+diff --git a/ip/ipl2tp.c b/ip/ipl2tp.c
+index 042ddb4..97f98b6 100644
+--- a/ip/ipl2tp.c
++++ b/ip/ipl2tp.c
+@@ -23,13 +23,6 @@
+ #include <linux/if_arp.h>
+ #include <linux/ip.h>
+
+-#include <netlink/netlink.h>
+-#include <netlink/genl/genl.h>
+-#include <netlink/genl/family.h>
+-#include <netlink/genl/mngt.h>
+-#include <netlink/genl/ctrl.h>
+-#include <netlink/utils.h>
+-
+ #include <linux/genetlink.h>
+ #include <linux/l2tp.h>
+
+--
+1.7.6.5
+