aboutsummaryrefslogtreecommitdiffstats
path: root/main/iproute2
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-29 12:20:16 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-29 12:20:16 +0000
commit97616d7c21376e9f7f2a45f0d0e65a7c5d96fd4f (patch)
tree03b8fda76b258df544ff613c36691691eda775fc /main/iproute2
parenta6be37c96770b878725e72bb8cab6f30a36b96a9 (diff)
downloadaports-97616d7c21376e9f7f2a45f0d0e65a7c5d96fd4f.tar.bz2
aports-97616d7c21376e9f7f2a45f0d0e65a7c5d96fd4f.tar.xz
main/iproute2: fix musl build
Diffstat (limited to 'main/iproute2')
-rw-r--r--main/iproute2/APKBUILD10
-rw-r--r--main/iproute2/fix-includes.patch40
2 files changed, 47 insertions, 3 deletions
diff --git a/main/iproute2/APKBUILD b/main/iproute2/APKBUILD
index 2979a0756a..fb0a8adcbe 100644
--- a/main/iproute2/APKBUILD
+++ b/main/iproute2/APKBUILD
@@ -12,6 +12,7 @@ install="$pkgname.post-install"
makedepends="bison flex bash iptables-dev"
subpackages="$pkgname-doc"
source="http://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz
+ fix-includes.patch
"
prepare() {
@@ -43,6 +44,9 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
-md5sums="45fb5427fc723a0001c72b92c931ba02 iproute2-3.10.0.tar.xz"
-sha256sums="c4023d8d722a1ed673474ca0e5a2d61ebd747cc7001a91321757422d9074c97e iproute2-3.10.0.tar.xz"
-sha512sums="afe81462e0d1ed4483cd7ab99abb15ccc9795fbd1276c162d0c8af236357d97fcbfc0ce3356f9ad94fbe048de9e13b2eb98cad60196d6cdbe1a3f2367887ce9f iproute2-3.10.0.tar.xz"
+md5sums="45fb5427fc723a0001c72b92c931ba02 iproute2-3.10.0.tar.xz
+914a7876074d4dca39eb80b98bf65091 fix-includes.patch"
+sha256sums="c4023d8d722a1ed673474ca0e5a2d61ebd747cc7001a91321757422d9074c97e iproute2-3.10.0.tar.xz
+14bd5601ebdb7a02a2f2c2eebed6adfe33249e4a394e5e5ecea75387ad82c4a3 fix-includes.patch"
+sha512sums="afe81462e0d1ed4483cd7ab99abb15ccc9795fbd1276c162d0c8af236357d97fcbfc0ce3356f9ad94fbe048de9e13b2eb98cad60196d6cdbe1a3f2367887ce9f iproute2-3.10.0.tar.xz
+9bdc960ea5c6cdc8db6f5197624f1faa778170122ac3c3d4e091921c761ba66edf660eebf9c64d467586cb18dd6a630cfbfb379ed45a9acad91cd4b37f4d0b16 fix-includes.patch"
diff --git a/main/iproute2/fix-includes.patch b/main/iproute2/fix-includes.patch
new file mode 100644
index 0000000000..23a0838d35
--- /dev/null
+++ b/main/iproute2/fix-includes.patch
@@ -0,0 +1,40 @@
+--- iproute2-3.10.0.orig/bridge/fdb.c
++++ iproute2-3.10.0/bridge/fdb.c
+@@ -12,6 +12,7 @@
+ #include <netdb.h>
+ #include <time.h>
+ #include <fcntl.h>
++#include <limits.h>
+ #include <sys/socket.h>
+ #include <sys/time.h>
+ #include <net/if.h>
+--- iproute2-3.10.0.orig/misc/lnstat.h
++++ iproute2-3.10.0/misc/lnstat.h
+@@ -2,6 +2,7 @@
+ #define _LNSTAT_H
+
+ #include <limits.h>
++#include <sys/select.h>
+
+ #define LNSTAT_VERSION "0.02 041002"
+
+--- iproute2-3.10.0.orig/tc/tc_stab.c
++++ iproute2-3.10.0/tc/tc_stab.c
+@@ -17,6 +17,7 @@
+ #include <fcntl.h>
+ #include <math.h>
+ #include <sys/socket.h>
++#include <sys/param.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <string.h>
+--- iproute2-3.10.0.orig/tc/tc_util.c
++++ iproute2-3.10.0/tc/tc_util.c
+@@ -18,6 +18,7 @@
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
++#include <sys/param.h>
+ #include <string.h>
+ #include <math.h>
+