aboutsummaryrefslogtreecommitdiffstats
path: root/main/iproute2
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-10 14:13:15 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-10 14:13:17 +0200
commitdeb1c0183c25f18e50e7a98fd501a697d5ff631a (patch)
tree2a0881c289bd0a01a36c40771ddc212149e904b5 /main/iproute2
parent1d410a22d713df45bab0a6d55b125314cd09a6d9 (diff)
downloadaports-deb1c0183c25f18e50e7a98fd501a697d5ff631a.tar.bz2
aports-deb1c0183c25f18e50e7a98fd501a697d5ff631a.tar.xz
main/iproute2: upgrade to 4.12.0
musl fixes have been copied from void linux.
Diffstat (limited to 'main/iproute2')
-rw-r--r--main/iproute2/APKBUILD9
-rw-r--r--main/iproute2/musl-fixes.patch270
2 files changed, 204 insertions, 75 deletions
diff --git a/main/iproute2/APKBUILD b/main/iproute2/APKBUILD
index 0ba11e140e..3feef4c187 100644
--- a/main/iproute2/APKBUILD
+++ b/main/iproute2/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iproute2
-pkgver=4.10.0
+pkgver=4.12.0
_realver=$pkgver
-pkgrel=1
+pkgrel=0
pkgdesc="IP Routing Utilities"
url="http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2"
arch="all"
@@ -14,6 +14,7 @@ subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
source="http://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz
musl-fixes.patch"
builddir="$srcdir"/$pkgname-$_realver
+patch_args="-p0"
prepare() {
default_prepare || return 1
@@ -55,5 +56,5 @@ bashcomp() {
rmdir -p "$pkgdir"/usr/share 2>/dev/null || true
}
-sha512sums="e54477e167455e7ef5da4adc168d63eaa96091b63dc987fffe918cbb005eceed18a62283ca99ee2512dc0e960f47ae21b39ffbe399c1612fd9cea147c34c581b iproute2-4.10.0.tar.xz
-93dd53e15a78cb9e408b1ca20f89a53838bfef8caa22615c2b504d28a429f93fa69e0762927481552275d544a26b1dba148e73151fd67d5971ebd2d3f57ed6c7 musl-fixes.patch"
+sha512sums="275147f71e7c4698654f0d6d0981ab42f6f108066508c15cfcd5d9e0d3aaf8d33291968d9f06cb03f5494d801cfabf8d53308aaf56fc4fa92c52b137e970a3b0 iproute2-4.12.0.tar.xz
+03f41867cc728d3fbf372ef00d8e90debd03671cff052f5e75dcfbeffbdb6e2c4b10d16e0737cdf473b063b710e8e2938a8f64cfa1be93da2c7878ce6ca51583 musl-fixes.patch"
diff --git a/main/iproute2/musl-fixes.patch b/main/iproute2/musl-fixes.patch
index ea50ed227a..0149f6daeb 100644
--- a/main/iproute2/musl-fixes.patch
+++ b/main/iproute2/musl-fixes.patch
@@ -1,48 +1,198 @@
-Don't redefine in6_addr due to including linux/in6.h; use netinet/in.h instead.
-
---- a/include/linux/if_bridge.h 2015-09-01 01:31:15.000000000 +0200
-+++ b/include/linux/if_bridge.h 2015-09-14 16:23:24.472434012 +0200
-@@ -15,7 +15,6 @@
+--- include/linux/if_ether.h 2017-07-06 11:09:53.305214044 -0700
++++ include/linux/if_ether.h 2017-07-06 16:30:06.651369931 -0700
+@@ -22,6 +22,7 @@
+ #define _LINUX_IF_ETHER_H
#include <linux/types.h>
- #include <linux/if_ether.h>
--#include <linux/in6.h>
++#include <linux/libc-compat.h>
+
+ /*
+ * IEEE 802.3 Ethernet magic constants. The frame sizes omit the preamble
+@@ -142,11 +143,13 @@
+ * This is an Ethernet frame header.
+ */
+
++#if __UAPI_DEF_ETHHDR
+ struct ethhdr {
+ unsigned char h_dest[ETH_ALEN]; /* destination eth addr */
+ unsigned char h_source[ETH_ALEN]; /* source ether addr */
+ __be16 h_proto; /* packet type ID field */
+ } __attribute__((packed));
++#endif
+
+
+ #endif /* _LINUX_IF_ETHER_H */
+--- include/linux/if_tunnel.h 2017-07-06 11:09:53.305214044 -0700
++++ include/linux/if_tunnel.h 2017-07-06 16:32:23.814172660 -0700
+@@ -2,7 +2,6 @@
+ #define _IF_TUNNEL_H_
- #define SYSFS_BRIDGE_ATTR "bridge"
- #define SYSFS_BRIDGE_FDB "brforward"
---- a/include/linux/netfilter.h 2015-09-01 01:31:15.000000000 +0200
-+++ b/include/linux/netfilter.h 2015-09-14 16:27:34.928205553 +0200
-@@ -4,8 +4,6 @@
#include <linux/types.h>
+-#include <linux/if.h>
+ #include <linux/ip.h>
+ #include <linux/in6.h>
+ #include <asm/byteorder.h>
+--- include/linux/ip6_tunnel.h 2017-07-06 11:09:53.303214021 -0700
++++ include/linux/ip6_tunnel.h 2017-07-06 16:33:41.630158864 -0700
+@@ -2,7 +2,6 @@
+ #define _IP6_TUNNEL_H
- #include <linux/sysctl.h>
--#include <linux/in.h>
--#include <linux/in6.h>
-
- /* Responses from hook functions. */
- #define NF_DROP 0
---- a/include/linux/xfrm.h 2015-09-01 01:31:15.000000000 +0200
-+++ b/include/linux/xfrm.h 2015-09-14 16:23:24.473434008 +0200
-@@ -1,7 +1,6 @@
- #ifndef _LINUX_XFRM_H
- #define _LINUX_XFRM_H
-
--#include <linux/in6.h>
#include <linux/types.h>
-
- /* All of the structures in this file may not change size as they are
---- a/include/utils.h 2015-09-01 01:31:15.000000000 +0200
-+++ b/include/utils.h 2015-09-14 16:23:24.472434012 +0200
-@@ -1,6 +1,7 @@
- #ifndef __UTILS_H__
- #define __UTILS_H__ 1
-
-+#include <sys/param.h> /* MAXPATHLEN */
- #include <sys/types.h>
- #include <asm/types.h>
- #include <resolv.h>
---- a/include/linux/netfilter_ipv4/ip_tables.h
-+++ b/include/linux/netfilter_ipv4/ip_tables.h
+-#include <linux/if.h> /* For IFNAMSIZ. */
+ #include <linux/in6.h> /* For struct in6_addr. */
+
+ #define IPV6_TLV_TNL_ENCAP_LIMIT 4
+--- include/linux/kernel.h 2017-07-06 11:09:53.303214021 -0700
++++ include/linux/kernel.h 2017-07-06 16:30:06.650369918 -0700
+@@ -1,7 +1,9 @@
+ #ifndef _LINUX_KERNEL_H
+ #define _LINUX_KERNEL_H
+
++#ifdef __GLIBC__
+ #include <linux/sysinfo.h>
++#endif
+
+ /*
+ * 'kernel.h' contains some often-used function prototypes etc
+--- include/linux/libc-compat.h 2017-07-06 11:09:53.302214010 -0700
++++ include/linux/libc-compat.h 2017-07-06 16:30:06.650369918 -0700
+@@ -48,47 +48,57 @@
+ #ifndef _LIBC_COMPAT_H
+ #define _LIBC_COMPAT_H
+
+-/* We have included glibc headers... */
+-#if defined(__GLIBC__)
++/* We're used from userspace... */
++#if !defined(__KERNEL__)
+
+-/* Coordinate with glibc net/if.h header. */
++/* Coordinate with libc net/if.h header. */
+ #if defined(_NET_IF_H) && defined(__USE_MISC)
+
+-/* GLIBC headers included first so don't define anything
++/* libc headers included first so don't define anything
+ * that would already be defined. */
+
+ #define __UAPI_DEF_IF_IFCONF 0
+ #define __UAPI_DEF_IF_IFMAP 0
+ #define __UAPI_DEF_IF_IFNAMSIZ 0
+ #define __UAPI_DEF_IF_IFREQ 0
+-/* Everything up to IFF_DYNAMIC, matches net/if.h until glibc 2.23 */
+ #define __UAPI_DEF_IF_NET_DEVICE_FLAGS 0
+-/* For the future if glibc adds IFF_LOWER_UP, IFF_DORMANT and IFF_ECHO */
++/* If libc adds IFF_LOWER_UP, IFF_DORMANT and IFF_ECHO */
++#if !defined(__GLIBC__)
++#define __UAPI_DEF_IF_NET_DEVICE_FLAGS_LOWER_UP_DORMANT_ECHO 0
++#else
+ #ifndef __UAPI_DEF_IF_NET_DEVICE_FLAGS_LOWER_UP_DORMANT_ECHO
+ #define __UAPI_DEF_IF_NET_DEVICE_FLAGS_LOWER_UP_DORMANT_ECHO 1
+ #endif /* __UAPI_DEF_IF_NET_DEVICE_FLAGS_LOWER_UP_DORMANT_ECHO */
++#endif /* !defined(__GLIBC__) */
+
+ #else /* _NET_IF_H */
+
+ /* Linux headers included first, and we must define everything
+- * we need. The expectation is that glibc will check the
++ * we need. The expectation is that libc will check the
+ * __UAPI_DEF_* defines and adjust appropriately. */
+
+ #define __UAPI_DEF_IF_IFCONF 1
+ #define __UAPI_DEF_IF_IFMAP 1
+ #define __UAPI_DEF_IF_IFNAMSIZ 1
+ #define __UAPI_DEF_IF_IFREQ 1
+-/* Everything up to IFF_DYNAMIC, matches net/if.h until glibc 2.23 */
+ #define __UAPI_DEF_IF_NET_DEVICE_FLAGS 1
+-/* For the future if glibc adds IFF_LOWER_UP, IFF_DORMANT and IFF_ECHO */
++/* If libc adds IFF_LOWER_UP, IFF_DORMANT and IFF_ECHO */
+ #define __UAPI_DEF_IF_NET_DEVICE_FLAGS_LOWER_UP_DORMANT_ECHO 1
+
+ #endif /* _NET_IF_H */
+
+-/* Coordinate with glibc netinet/in.h header. */
++/* Coordinate with libc netinet/if_ether.h */
++#ifdef _NETINET_IF_ETHER_H
++#define __UAPI_DEF_ETHHDR 0
++#else
++/* glibc uses __NETINET_IF_ETHER_H and uses the uapi header */
++#define __UAPI_DEF_ETHHDR 1
++#endif /* _NETINET_IF_ETHER_H */
++
++/* Coordinate with libc netinet/in.h header. */
+ #if defined(_NETINET_IN_H)
+
+-/* GLIBC headers included first so don't define anything
++/* libc headers included first so don't define anything
+ * that would already be defined. */
+ #define __UAPI_DEF_IN_ADDR 0
+ #define __UAPI_DEF_IN_IPPROTO 0
+@@ -98,15 +108,7 @@
+ #define __UAPI_DEF_IN_CLASS 0
+
+ #define __UAPI_DEF_IN6_ADDR 0
+-/* The exception is the in6_addr macros which must be defined
+- * if the glibc code didn't define them. This guard matches
+- * the guard in glibc/inet/netinet/in.h which defines the
+- * additional in6_addr macros e.g. s6_addr16, and s6_addr32. */
+-#if defined(__USE_MISC) || defined (__USE_GNU)
+ #define __UAPI_DEF_IN6_ADDR_ALT 0
+-#else
+-#define __UAPI_DEF_IN6_ADDR_ALT 1
+-#endif
+ #define __UAPI_DEF_SOCKADDR_IN6 0
+ #define __UAPI_DEF_IPV6_MREQ 0
+ #define __UAPI_DEF_IPPROTO_V6 0
+@@ -117,7 +119,7 @@
+ #else
+
+ /* Linux headers included first, and we must define everything
+- * we need. The expectation is that glibc will check the
++ * we need. The expectation is that libc will check the
+ * __UAPI_DEF_* defines and adjust appropriately. */
+ #define __UAPI_DEF_IN_ADDR 1
+ #define __UAPI_DEF_IN_IPPROTO 1
+@@ -127,7 +129,7 @@
+ #define __UAPI_DEF_IN_CLASS 1
+
+ #define __UAPI_DEF_IN6_ADDR 1
+-/* We unconditionally define the in6_addr macros and glibc must
++/* We unconditionally define the in6_addr macros and libc must
+ * coordinate. */
+ #define __UAPI_DEF_IN6_ADDR_ALT 1
+ #define __UAPI_DEF_SOCKADDR_IN6 1
+@@ -168,18 +170,20 @@
+ /* If we did not see any headers from any supported C libraries,
+ * or we are being included in the kernel, then define everything
+ * that we need. */
+-#else /* !defined(__GLIBC__) */
++#else /* defined(__KERNEL__) */
+
+ /* Definitions for if.h */
+ #define __UAPI_DEF_IF_IFCONF 1
+ #define __UAPI_DEF_IF_IFMAP 1
+ #define __UAPI_DEF_IF_IFNAMSIZ 1
+ #define __UAPI_DEF_IF_IFREQ 1
+-/* Everything up to IFF_DYNAMIC, matches net/if.h until glibc 2.23 */
+ #define __UAPI_DEF_IF_NET_DEVICE_FLAGS 1
+-/* For the future if glibc adds IFF_LOWER_UP, IFF_DORMANT and IFF_ECHO */
++/* If libc adds IFF_LOWER_UP, IFF_DORMANT and IFF_ECHO */
+ #define __UAPI_DEF_IF_NET_DEVICE_FLAGS_LOWER_UP_DORMANT_ECHO 1
+
++/* Definitions for if/ether.h */
++#define __UAPI_DEF_ETHHDR 1
++
+ /* Definitions for in.h */
+ #define __UAPI_DEF_IN_ADDR 1
+ #define __UAPI_DEF_IN_IPPROTO 1
+@@ -208,6 +212,6 @@
+ /* Definitions for xattr.h */
+ #define __UAPI_DEF_XATTR 1
+
+-#endif /* __GLIBC__ */
++#endif /* defined(__KERNEL__) */
+
+ #endif /* _LIBC_COMPAT_H */
+--- include/linux/netfilter_ipv4/ip_tables.h 2017-07-06 11:09:53.310214100 -0700
++++ include/linux/netfilter_ipv4/ip_tables.h 2017-07-06 16:38:57.526211238 -0700
@@ -17,7 +17,6 @@
#include <linux/types.h>
@@ -51,36 +201,14 @@ Don't redefine in6_addr due to including linux/in6.h; use netinet/in.h instead.
#include <linux/netfilter_ipv4.h>
#include <linux/netfilter/x_tables.h>
---- a/include/bpf_scm.h
-+++ b/include/bpf_scm.h
-@@ -3,6 +3,7 @@
-
- #include <sys/types.h>
- #include <sys/socket.h>
-+#include <sys/un.h>
-
- #include "utils.h"
- #include "bpf_elf.h"
---- a/include/linux/if_tunnel.h
-+++ b/include/linux/if_tunnel.h
-@@ -2,9 +2,7 @@
- #define _IF_TUNNEL_H_
-
- #include <linux/types.h>
--#include <linux/if.h>
+--- tc/f_flower.c 2017-07-06 11:09:53.289213865 -0700
++++ tc/f_flower.c 2017-07-06 16:36:04.967030780 -0700
+@@ -15,7 +15,7 @@
+ #include <syslog.h>
+ #include <string.h>
+ #include <net/if.h>
+-#include <linux/if_arp.h>
++#include <net/if_arp.h>
+ #include <linux/if_ether.h>
#include <linux/ip.h>
--#include <linux/in6.h>
- #include <asm/byteorder.h>
-
-
---- a/include/linux/l2tp.h
-+++ b/include/linux/l2tp.h
-@@ -9,8 +9,6 @@
-
- #include <linux/types.h>
- #include <linux/socket.h>
--#include <linux/in.h>
--#include <linux/in6.h>
-
- #define IPPROTO_L2TP 115
-
+ #include <linux/tc_act/tc_vlan.h>