aboutsummaryrefslogtreecommitdiffstats
path: root/main/iptables
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2018-12-09 02:07:58 +0100
committerFrancesco Colista <fcolista@alpinelinux.org>2018-12-11 07:45:44 +0000
commit5721d5480eac1d1b0d0e14a3e3bff9b8e7a29982 (patch)
tree83a8b0daafe66d4676ac4201bc2c8faf91b97411 /main/iptables
parent2bec02625c0b48259def09296f107692c6cedad5 (diff)
downloadaports-5721d5480eac1d1b0d0e14a3e3bff9b8e7a29982.tar.bz2
aports-5721d5480eac1d1b0d0e14a3e3bff9b8e7a29982.tar.xz
main/iptables: upgrade to 1.8.2
Diffstat (limited to 'main/iptables')
-rw-r--r--main/iptables/APKBUILD12
-rw-r--r--main/iptables/iptables-1.8.2-musl-fixes.patch (renamed from main/iptables/iptables-1.6.0-musl-fixes.patch)27
2 files changed, 27 insertions, 12 deletions
diff --git a/main/iptables/APKBUILD b/main/iptables/APKBUILD
index d9f2902f70..df786537c4 100644
--- a/main/iptables/APKBUILD
+++ b/main/iptables/APKBUILD
@@ -1,17 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iptables
-pkgver=1.6.2
+pkgver=1.8.2
pkgrel=0
pkgdesc="Linux kernel firewall, NAT and packet mangling tools"
-url="http://www.netfilter.org/projects/iptables/index.html"
+url="https://www.netfilter.org/projects/iptables/index.html"
arch="all"
license="GPL-2.0-or-later"
depends_dev="linux-headers"
makedepends="$depends_dev libnftnl-dev bison flex autoconf automake"
subpackages="ip6tables $pkgname-doc $pkgname-dev"
-source="http://ftp.netfilter.org/pub/iptables/iptables-$pkgver.tar.bz2
- iptables-1.6.0-musl-fixes.patch
+source="https://www.netfilter.org/projects/iptables/files/iptables-$pkgver.tar.bz2
+ iptables-1.8.2-musl-fixes.patch
iptables.initd
iptables.confd
ip6tables.confd
@@ -83,8 +83,8 @@ ip6tables() {
install -D -m644 "$srcdir"/ip6tables.confd etc/conf.d/ip6tables
}
-sha512sums="04f22e969c794246b9aa28055b202638081cfb0bb4a5625c049a30c48ac84cdd41db12a53c5831398cfe47c8f5691aa02b30b0ae3b5afe0f20ec48cf86a799c0 iptables-1.6.2.tar.bz2
-e79344cab67c4fa0449dfeef6d1504bcd41d16d595010a18a7d9e75eba46021617d31fbb79c62894fd35898ec643b542a6111b06d405c79ffff41a3078327b62 iptables-1.6.0-musl-fixes.patch
+sha512sums="8cf0f515764e1dc6e03284581d682d1949b33e8f25fea29c27ae856f1089fe8ca7b1814524b85f4378fd1fc7c7c7d002f06557b257ae2bbc945f8555bad0dc76 iptables-1.8.2.tar.bz2
+8fd1e26c5bb7d6fa2c7f24d2c81711a6f9ed062c671a0a5a17bfafa40193b1f53ff358395eb6fc596a9ae24505e7443567b0a40d22c6a590f710c7dc8dc73699 iptables-1.8.2-musl-fixes.patch
059b3bd8dd7dec60060ec5eb1e639fe8203207629f3a7dd4fdbe5ebca3f7e9b80df5592ebb27542e31830fd15a53cffac5772567053c104dfccf9b78613a31a1 iptables.initd
cb7fecd5cab2c78bd3f215a41f39ec11c37eb360efbe83982378a0e647e0aa9dc0b7ec915a5b5081aa2f7747464787e69404aa15ba15a063c32cb8fb7dd13d1e iptables.confd
0897a7a22f8b700f7f1f5c355ad6cbf39740e44d6c962af99e479978d8a2d556ca7fe4e31f238829046b4a871ce0b5fd52e2544f1361d15dd1ea3e33992646c4 ip6tables.confd"
diff --git a/main/iptables/iptables-1.6.0-musl-fixes.patch b/main/iptables/iptables-1.8.2-musl-fixes.patch
index 4a89e19999..71d879b144 100644
--- a/main/iptables/iptables-1.6.0-musl-fixes.patch
+++ b/main/iptables/iptables-1.8.2-musl-fixes.patch
@@ -1,5 +1,5 @@
---- iptables-1.4.12.1.o/extensions/libip6t_ipv6header.c
-+++ iptables-1.4.12.1/extensions/libip6t_ipv6header.c
+--- a/extensions/libip6t_ipv6header.c
++++ b/extensions/libip6t_ipv6header.c
@@ -10,6 +10,9 @@
#include <netdb.h>
#include <xtables.h>
@@ -10,8 +10,8 @@
enum {
O_HEADER = 0,
---- iptables-1.4.12.1.o/extensions/libxt_TCPOPTSTRIP.c
-+++ iptables-1.4.12.1/extensions/libxt_TCPOPTSTRIP.c
+--- a/extensions/libxt_TCPOPTSTRIP.c
++++ b/extensions/libxt_TCPOPTSTRIP.c
@@ -12,6 +12,21 @@
#ifndef TCPOPT_MD5SIG
# define TCPOPT_MD5SIG 19
@@ -34,8 +34,8 @@
enum {
O_STRIP_OPTION = 0,
---- iptables-1.4.12.1.o/include/linux/netfilter_ipv4/ip_tables.h
-+++ iptables-1.4.12.1/include/linux/netfilter_ipv4/ip_tables.h
+--- a/include/linux/netfilter_ipv4/ip_tables.h
++++ b/include/linux/netfilter_ipv4/ip_tables.h
@@ -16,6 +16,7 @@
#define _IPTABLES_H
@@ -43,3 +43,18 @@
+#include <sys/types.h>
#include <linux/netfilter_ipv4.h>
+
+--- a/extensions/libebt_vlan.c
++++ b/extensions/libebt_vlan.c
+@@ -13,7 +13,11 @@
+ #include <ctype.h>
+ #include <xtables.h>
+ #include <linux/netfilter_bridge/ebt_vlan.h>
++#if defined (__GLIBC__)
+ #include <linux/if_ether.h>
++#else
++#include <net/ethernet.h>
++#endif
+ #include "iptables/nft.h"
+ #include "iptables/nft-bridge.h"
+