aboutsummaryrefslogtreecommitdiffstats
path: root/main/iputils
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-09-19 17:55:57 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-10-22 13:16:58 +0000
commite76dec005c37611a0866ea6456208758d337c749 (patch)
treea1a8fa9a5cf0b3923b943bfc11f8c92ff77d9053 /main/iputils
parentb7540286a403f0bfb771fd23239390c80f5fb2ab (diff)
downloadaports-e76dec005c37611a0866ea6456208758d337c749.tar.bz2
aports-e76dec005c37611a0866ea6456208758d337c749.tar.xz
main/iputils: upgrade to 20190709
build with meson because upstream switched to it change source to github.com where development is moved remove obsolete patches
Diffstat (limited to 'main/iputils')
-rw-r--r--main/iputils/APKBUILD33
-rw-r--r--main/iputils/fix-defines.patch13
-rw-r--r--main/iputils/fix-init-of-cmsg.patch20
3 files changed, 20 insertions, 46 deletions
diff --git a/main/iputils/APKBUILD b/main/iputils/APKBUILD
index ee6240099c..670046e94e 100644
--- a/main/iputils/APKBUILD
+++ b/main/iputils/APKBUILD
@@ -1,30 +1,39 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iputils
-pkgver=20180629
-pkgrel=1
+pkgver=20190709
+pkgrel=0
pkgdesc="IP Configuration Utilities (and Ping)"
url="https://github.com/iputils/iputils/"
arch="all"
license="BSD-3-Clause GPL-2.0-or-later"
-makedepends="libcap-dev openssl-dev"
+makedepends="libcap-dev openssl-dev meson"
replaces="bbsuid"
-source="https://github.com/iputils/$pkgname/archive/s$pkgver.tar.gz
- fix-init-of-cmsg.patch
- fix-defines.patch
- "
+source="https://github.com/iputils/$pkgname/archive/s$pkgver.tar.gz"
options="!check suid"
builddir="$srcdir/$pkgname-s$pkgver"
build() {
cd "$builddir"
- make all ninfod USE_IDN=no USE_NETTLE=no KERNEL_INCLUDE=/usr/include
+
+ meson \
+ --buildtype=plain \
+ --prefix="/usr" \
+ --sbindir="bin" \
+ -DNO_SETCAP_OR_SUID=true \
+ -DBUILD_RARPD=true \
+ -DBUILD_TRACEROUTE6=true \
+ -DBUILD_MANS=false \
+ -DUSE_IDN=false \
+ -DUSE_GETTEXT=false \
+ "build"
+ ninja -C "build"
}
package() {
local name
- cd "$builddir"
+ cd "$builddir"/build
- for name in arping clockdiff ipg rarpd rdisc tftpd tracepath; do
+ for name in arping clockdiff rarpd rdisc tftpd tracepath; do
install -D -m755 $name "$pkgdir"/usr/sbin/$name
done
install -D -m755 ninfod/ninfod "$pkgdir"/usr/sbin/ninfod
@@ -37,6 +46,4 @@ package() {
ln -s ping "$pkgdir"/bin/ping6
}
-sha512sums="16b8f5ad1cf88083ebaee0a71fddb14bb0a904336fd0baebfcca86c27ac0773553b21d12790b05cab7661d6432c75bbb1523e871e5e1b77faacd13ccc84f4476 s20180629.tar.gz
-2779b9d987089a2a9a39c27a092f16da85881e9dfbc99edcca6baea42912b8a1a7e16b00c19684d2ea1a6123d66f78be12bef43398e63be7d7c97d3d6269a5bf fix-init-of-cmsg.patch
-85c766b2cd738aeedb8dda8100af5814d9c0b4b62d6e98ca4329e3d34b19845e34bde772ca27e79360b7911cdb51bad11ca8f7717a367286c08243471fb32c47 fix-defines.patch"
+sha512sums="5db18ac49fa46ed810da4d508e78f4baf2d5c07e7f923eb49d005ad8745743d8861e5788b34a7e37fb7261cee7ddfb768b737eee9d200502ea53537142cac6b5 s20190709.tar.gz"
diff --git a/main/iputils/fix-defines.patch b/main/iputils/fix-defines.patch
deleted file mode 100644
index 13a2060327..0000000000
--- a/main/iputils/fix-defines.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/ping.h
-+++ b/ping.h
-@@ -44,6 +44,10 @@
- #define getnameinfo_flags 0
- #endif
-
-+#ifndef AI_CANONIDN
-+#define AI_CANONIDN 0x0080
-+#endif
-+
- #ifndef WITHOUT_IFADDRS
- #include <ifaddrs.h>
- #endif
diff --git a/main/iputils/fix-init-of-cmsg.patch b/main/iputils/fix-init-of-cmsg.patch
deleted file mode 100644
index 76ebc16c25..0000000000
--- a/main/iputils/fix-init-of-cmsg.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Fixes ping on s390x.
-
-diff --git a/ping.c b/ping.c
-index a0857a1..329553d 100644
---- a/ping.c
-+++ b/ping.c
-@@ -108,8 +108,11 @@ static int parsetos(char *str);
- static struct {
- struct cmsghdr cm;
- struct in_pktinfo ipi;
--} cmsg = { {sizeof(struct cmsghdr) + sizeof(struct in_pktinfo), SOL_IP, IP_PKTINFO},
-- {0, }};
-+} cmsg = { .cm = {
-+ .cmsg_len = sizeof(struct cmsghdr) + sizeof(struct in_pktinfo),
-+ .cmsg_level = SOL_IP,
-+ .cmsg_type = IP_PKTINFO},
-+ .ipi = {0, }};
- int cmsg_len;
-
- struct sockaddr_in source;