aboutsummaryrefslogtreecommitdiffstats
path: root/main/itstool
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-11-21 11:49:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-21 11:49:11 +0000
commit2cf064f35ab32c9b1aaf014b233a49e73dbb4fe7 (patch)
tree9fc5e860d2cac12d8ad6050b70da422e957d3425 /main/itstool
parent95bf391123cdaa62c0392a9fc9996220c3b3b025 (diff)
downloadaports-2cf064f35ab32c9b1aaf014b233a49e73dbb4fe7.tar.bz2
aports-2cf064f35ab32c9b1aaf014b233a49e73dbb4fe7.tar.xz
main/itstool: fix shebang
we need specify the full path so the shebang gets correct, otherwise will configure script set it to `#!python3` which does not work also add regression test for this issue
Diffstat (limited to 'main/itstool')
-rw-r--r--main/itstool/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/main/itstool/APKBUILD b/main/itstool/APKBUILD
index 98ac7a3317..ae9a91e72c 100644
--- a/main/itstool/APKBUILD
+++ b/main/itstool/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=itstool
pkgver=2.0.4
-pkgrel=2
+pkgrel=3
pkgdesc="ITS-based XML translation tool"
url="http://itstool.org/"
arch="noarch"
@@ -15,7 +15,7 @@ builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- PYTHON="python3" ./configure \
+ PYTHON="/usr/bin/python3" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -29,6 +29,9 @@ build() {
check() {
cd "$builddir"
make check
+ # verify that the shebang is correct
+ chmod +x itstool
+ ./itstool
}
package() {