aboutsummaryrefslogtreecommitdiffstats
path: root/main/jbig2dec/APKBUILD
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-12-13 05:51:24 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-18 14:01:25 +0000
commit52a93aff8bb1bef6f531b810050b6bb24e4a13c1 (patch)
tree54cc760f3c092b855924917a84a1d259ddc8ad6b /main/jbig2dec/APKBUILD
parentb889d88f055665e0b690f8a8683172cabfe88406 (diff)
downloadaports-52a93aff8bb1bef6f531b810050b6bb24e4a13c1.tar.bz2
aports-52a93aff8bb1bef6f531b810050b6bb24e4a13c1.tar.xz
main/jbig2dec: upgrade to 0.15, enable tests
./CHANGES claims "many security related and stability fixes". While here, enable built-in test suite (passes on x86_64 and mipseln8hf at least) and make sure libpng is not pulled accidentally during build. Pull the source from github.com as referenced on the project's web page.
Diffstat (limited to 'main/jbig2dec/APKBUILD')
-rw-r--r--main/jbig2dec/APKBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/main/jbig2dec/APKBUILD b/main/jbig2dec/APKBUILD
index f8786edbae..b4396b7869 100644
--- a/main/jbig2dec/APKBUILD
+++ b/main/jbig2dec/APKBUILD
@@ -1,15 +1,16 @@
# Contributor: Michael Zhou <zhoumichaely@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=jbig2dec
-pkgver=0.14
+pkgver=0.15
pkgrel=0
pkgdesc="JBIG2 image compression format decoder"
url="https://www.ghostscript.com/jbig2dec.html"
arch="all"
license="GPL-2.0-or-later"
makedepends="autoconf automake libtool"
+checkdepends="python2"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://downloads.ghostscript.com/public/jbig2dec/jbig2dec-$pkgver.tar.gz"
+source="https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs924/jbig2dec-0.15.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -21,17 +22,26 @@ prepare() {
build() {
cd "$builddir"
- ./configure --prefix=/usr \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var
+ --localstatedir=/var \
+ --without-libpng
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="066bd880ac0665fc1e42b0ae0e481008b125aab6e173b7f82d61a2a30e72c90085cbded9b2a68c6836f92dea3d8d8d5c2228dba76e0d99c79c922197d215705b jbig2dec-0.14.tar.gz"
+sha512sums="142acf0c47be094232ff21074414be5cf633a7008b2095d60b8878c4e125966f36632d8db191959ae1ac4b12b8fdc78139f67cd531717d203864b459d2570369 jbig2dec-0.15.tar.gz"