aboutsummaryrefslogtreecommitdiffstats
path: root/main/json-c0.12/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:26:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-23 12:07:30 -0300
commit41ab224df12b8487004a1522b4f671680c082954 (patch)
tree9ebbc4ea5d1cfb82757ca1fd862b67e444a712a2 /main/json-c0.12/APKBUILD
parent1f40937c55d742c7ae05db34c966c3dd2d6595e7 (diff)
downloadaports-41ab224df12b8487004a1522b4f671680c082954.tar.bz2
aports-41ab224df12b8487004a1522b4f671680c082954.tar.xz
community/*: move lots of stuff from main and modernize
Diffstat (limited to 'main/json-c0.12/APKBUILD')
-rw-r--r--main/json-c0.12/APKBUILD49
1 files changed, 0 insertions, 49 deletions
diff --git a/main/json-c0.12/APKBUILD b/main/json-c0.12/APKBUILD
deleted file mode 100644
index 2cf2388cfd..0000000000
--- a/main/json-c0.12/APKBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=json-c0.12
-pkgver=0.12.1
-pkgrel=2
-pkgdesc="A JSON implementation in C"
-url="https://github.com/json-c/json-c/wiki"
-arch="all"
-license="MIT"
-makedepends=" autoconf automake libtool"
-subpackages="$pkgname-dev"
-replaces="json-c"
-source="https://s3.amazonaws.com/json-c_releases/releases/json-c-${pkgver}.tar.gz
- "
-
-builddir="$srcdir"/json-c-$pkgver
-prepare() {
- cd "$builddir"
- default_prepare
- autoreconf -f -v -i
-}
-
-build() {
- cd "$builddir"
- export CFLAGS="${CFLAGS} -Wno-error=unused-but-set-variable -Wno-error=implicit-fallthrough"
- ./configure --prefix=/usr \
- --build=$CBUILD \
- --host=$CHOST \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --enable-shared \
- --disable-static \
- ac_cv_func_malloc_0_nonnull=yes \
- ac_cv_func_realloc_0_nonnull=yes
- make -j1
-}
-
-check() {
- cd "$builddir"
- make USE_VALGRIND=0 check
-}
-
-package() {
- cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install
-}
-
-sha512sums="038676a0ce815e5174161fbd4339524feadc294d517f732fb408ad6aa7c4906423451c13386107569d9f24746a1a101564ca511e92e8276c5bf5b8c022ca42ed json-c-0.12.1.tar.gz"