aboutsummaryrefslogtreecommitdiffstats
path: root/main/kbd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-08-26 15:49:05 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-08-26 15:49:05 +0200
commit07977bb98d2371f4aca6293ab51e3d11bb2ff98f (patch)
tree5e3f1b6342acb36e85b31c786dd819cf1ec9f577 /main/kbd
parent1084f7e6768b0c81b86c2b7a99cacb328a36420a (diff)
downloadaports-07977bb98d2371f4aca6293ab51e3d11bb2ff98f.tar.bz2
aports-07977bb98d2371f4aca6293ab51e3d11bb2ff98f.tar.xz
main/kbd: upgrade to 2.0.3
Diffstat (limited to 'main/kbd')
-rw-r--r--main/kbd/0001-Replace-u_short-with-unsigned-short.patch92
-rw-r--r--main/kbd/0002-Fix-required-header-includes.patch42
-rw-r--r--main/kbd/0003-Only-inluclude-kernel-headers-with-glibc.patch28
-rw-r--r--main/kbd/APKBUILD22
4 files changed, 5 insertions, 179 deletions
diff --git a/main/kbd/0001-Replace-u_short-with-unsigned-short.patch b/main/kbd/0001-Replace-u_short-with-unsigned-short.patch
deleted file mode 100644
index cefcbe8e15..0000000000
--- a/main/kbd/0001-Replace-u_short-with-unsigned-short.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-From 4c61d59e9c85e26cee306ed1b964030c1e862e00 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 20 Aug 2014 08:44:41 +0200
-Subject: [PATCH 1/4] Replace u_short with unsigned short
-
-u_short is non-standard and causes build failure with musl libc.
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- src/libkeymap/dump.c | 6 +++---
- src/libkeymap/kmap.c | 6 +++---
- src/libkeymap/summary.c | 2 +-
- 3 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/src/libkeymap/dump.c b/src/libkeymap/dump.c
-index 0262e24..e0c502e 100644
---- a/src/libkeymap/dump.c
-+++ b/src/libkeymap/dump.c
-@@ -69,7 +69,7 @@ lk_dump_bkeymap(struct lk_ctx *ctx, FILE *fd)
- continue;
-
- for (j = 0; j < NR_KEYS / 2; j++) {
-- u_short v;
-+ unsigned short v;
- v = lk_get_key(ctx, i, j);
-
- if (fwrite(&v, sizeof(v), 1, fd) != 1)
-@@ -130,7 +130,7 @@ lk_dump_ctable(struct lk_ctx *ctx, FILE *fd)
- if (lk_map_exists(ctx, i)) {
- if (i)
- fprintf(fd, "static ");
-- fprintf(fd, "u_short %s_map[NR_KEYS] = {", mk_mapname(i));
-+ fprintf(fd, "unsigned short %s_map[NR_KEYS] = {", mk_mapname(i));
- for (j = 0; j < NR_KEYS; j++) {
- if (!(j % 8))
- fprintf(fd, "\n");
-@@ -489,7 +489,7 @@ no_shorthands:
-
- isasexpected = 0;
- if (isletter) {
-- u_short defs[16];
-+ unsigned short defs[16];
- defs[0] = K(KT_LETTER, val);
- defs[1] = K(KT_LETTER, val ^ 32);
- defs[2] = defs[0];
-diff --git a/src/libkeymap/kmap.c b/src/libkeymap/kmap.c
-index 67be81e..8b90654 100644
---- a/src/libkeymap/kmap.c
-+++ b/src/libkeymap/kmap.c
-@@ -173,7 +173,7 @@ lk_add_key(struct lk_ctx *ctx, unsigned int k_table, unsigned int k_index, int k
- }
-
- static int
--do_constant_key(struct lk_ctx *ctx, int i, u_short key)
-+do_constant_key(struct lk_ctx *ctx, int i, unsigned short key)
- {
- int typ, val;
- unsigned int j;
-@@ -183,7 +183,7 @@ do_constant_key(struct lk_ctx *ctx, int i, u_short key)
-
- if ((typ == KT_LATIN || typ == KT_LETTER) &&
- ((val >= 'a' && val <= 'z') || (val >= 'A' && val <= 'Z'))) {
-- u_short defs[16];
-+ unsigned short defs[16];
- defs[0] = K(KT_LETTER, val);
- defs[1] = K(KT_LETTER, val ^ 32);
- defs[2] = defs[0];
-@@ -235,7 +235,7 @@ lk_add_constants(struct lk_ctx *ctx)
-
- for (i = 0; i < ctx->key_constant->total; i++) {
- char *constant;
-- u_short key;
-+ unsigned short key;
-
- constant = lk_array_get(ctx->key_constant, i);
- if (!constant || !(*constant))
-diff --git a/src/libkeymap/summary.c b/src/libkeymap/summary.c
-index 46df90d..44d4e5f 100644
---- a/src/libkeymap/summary.c
-+++ b/src/libkeymap/summary.c
-@@ -30,7 +30,7 @@ valid_type(int fd, int t)
- return (ioctl(fd, KDSKBENT, (unsigned long) &ke) == 0);
- }
-
--static u_char
-+static unsigned char
- maximum_val(int fd, int t)
- {
- struct kbentry ke, ke0;
---
-2.1.0
-
diff --git a/main/kbd/0002-Fix-required-header-includes.patch b/main/kbd/0002-Fix-required-header-includes.patch
deleted file mode 100644
index dff221ecef..0000000000
--- a/main/kbd/0002-Fix-required-header-includes.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From b856e52cd6e76a105aad8ddfcd2b123203b687c1 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 20 Aug 2014 08:47:50 +0200
-Subject: [PATCH 2/4] Fix required header includes
-
-We need fcntl.h for open(2) and limits.h for NAME_MAX for compiling
-with musl libc.
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- src/kbdrate.c | 1 +
- src/openvt.c | 2 ++
- 2 files changed, 3 insertions(+)
-
-diff --git a/src/kbdrate.c b/src/kbdrate.c
-index 2ab8388..aa66622 100644
---- a/src/kbdrate.c
-+++ b/src/kbdrate.c
-@@ -72,6 +72,7 @@ beats rebuilding the kernel!
- #include <unistd.h>
- #include <stdlib.h>
- #include <errno.h>
-+#include <fcntl.h>
- #include <sys/file.h>
- #include <sys/ioctl.h>
- #include <linux/kd.h>
-diff --git a/src/openvt.c b/src/openvt.c
-index 075136f..70d37d8 100644
---- a/src/openvt.c
-+++ b/src/openvt.c
-@@ -5,6 +5,8 @@
- #include <dirent.h>
- #include <pwd.h>
- #include <errno.h>
-+#include <fcntl.h>
-+#include <limits.h>
- #include <sys/ioctl.h>
- #include <sys/stat.h>
- #include <sys/vt.h>
---
-2.1.0
-
diff --git a/main/kbd/0003-Only-inluclude-kernel-headers-with-glibc.patch b/main/kbd/0003-Only-inluclude-kernel-headers-with-glibc.patch
deleted file mode 100644
index 1b01f3608e..0000000000
--- a/main/kbd/0003-Only-inluclude-kernel-headers-with-glibc.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 3c5c7acc7ef874b919b26583d3892e21b907833f Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 20 Aug 2014 09:00:03 +0200
-Subject: [PATCH 3/4] Only inluclude kernel headers with glibc
-
-This fixes compile errors with musl libc
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- src/resizecons.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/resizecons.c b/src/resizecons.c
-index 5f84845..691dfcc 100644
---- a/src/resizecons.c
-+++ b/src/resizecons.c
-@@ -80,7 +80,7 @@
- #include <sys/ioctl.h>
- #if (__GNU_LIBRARY__ >= 6)
- #include <sys/perm.h>
--#else
-+#elif defined(__GLIBC__)
- #include <linux/types.h>
- #include <linux/termios.h>
- #endif
---
-2.1.0
-
diff --git a/main/kbd/APKBUILD b/main/kbd/APKBUILD
index e4f11c616f..d5feb0f9cd 100644
--- a/main/kbd/APKBUILD
+++ b/main/kbd/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=kbd
-pkgver=2.0.2
-pkgrel=1
+pkgver=2.0.3
+pkgrel=0
pkgdesc="Tools for configuring the console (keyboard, virtual terminals, etc.)"
url="http://ftp.altlinux.org/pub/people/legion/kbd"
arch="all"
@@ -12,9 +12,6 @@ makedepends="linux-headers bison flex autoconf automake linux-pam-dev check-dev"
install=""
subpackages="$pkgname-misc $pkgname-doc"
source="ftp://ftp.altlinux.org/pub/people/legion/kbd/kbd-$pkgver.tar.gz
- 0001-Replace-u_short-with-unsigned-short.patch
- 0002-Fix-required-header-includes.patch
- 0003-Only-inluclude-kernel-headers-with-glibc.patch
error.h
"
@@ -101,18 +98,9 @@ misc() {
done
}
-md5sums="f1f75f0dd5f7dde89ce47585274366f8 kbd-2.0.2.tar.gz
-7945e2d7f13cc2896233bf5e1de8e4e2 0001-Replace-u_short-with-unsigned-short.patch
-4e04e0c7307e89193b7dc2cd889be0a5 0002-Fix-required-header-includes.patch
-31027a70335ff0a5e9f3b779d70920ce 0003-Only-inluclude-kernel-headers-with-glibc.patch
+md5sums="d636ee56f35233b5cd6f855c08372489 kbd-2.0.3.tar.gz
1a5b152db18674deec07ab7c6209267a error.h"
-sha256sums="b1e4c796601039d3b63da908c27431a36e7af06d4d964cd3f8821a880eb3c021 kbd-2.0.2.tar.gz
-d55432213b14d677af73eb5b919327bd9fe03dd6fcad059f5d345901d6029e96 0001-Replace-u_short-with-unsigned-short.patch
-e1e6c482d4c00ace48938f4888a23992ae3cc16674a0d5d1f1f07eb57afac550 0002-Fix-required-header-includes.patch
-e2d49d91309b6b2450de7aa32be1807284958cf66cd9e4ee823dbb0afaf11772 0003-Only-inluclude-kernel-headers-with-glibc.patch
+sha256sums="1933a9a9607a88fddb798f4c1df44ca81257733756c480567ceb52a41de273b9 kbd-2.0.3.tar.gz
0124ef103407469af4ea19884e2ed7e4546f08b58c129e1e8ef36569831f4b36 error.h"
-sha512sums="68832bddd6b91693110d1e26d3911bcd3c151003f83905571dcba05480ba484adc5bfe7d31a3b987bd930703d153724fb8eb9ae7cc26cff97be65a4f5ccb547b kbd-2.0.2.tar.gz
-0487a90382201a162405618e983fb2a227c6f07258a498c6850b5ddcd36d5c836446b4c7883a494421a3dc34a60b164bb6ce10350c777bc0cb1f610d4fe6a0ca 0001-Replace-u_short-with-unsigned-short.patch
-c3689db8777566dd92c6d38fadc1d8676d00926c711d5bb8b561547aaeb4d93b67998ac3f2b17faaa475e7c85a9e51c71b87cd92b6099ee118c19de58bc195aa 0002-Fix-required-header-includes.patch
-13af714a54562ebc1ac6b19f24f75704b452faf543705e9e6a8c53e8080f5edffb49ddde26a876da71e6ca34b275c3407525d6d3446c543181d2eff2b784541b 0003-Only-inluclude-kernel-headers-with-glibc.patch
+sha512sums="7d9a8aa74de45796b8045ddbeaacd1b8fb9e9fd297c18ff382817c40d86bca421978664b215de0b7f79f316437d0c8bc259a113bfb92eb06d106f044339012d8 kbd-2.0.3.tar.gz
c66f6b0d8c8b8d285c740bdbe7130dee272ac01cd5e73b35a58cedf1a77fe8d9e062631b804fb58014d8eb9861c8f28aed07bc022ef31662bcc61b5c85a21752 error.h"