aboutsummaryrefslogtreecommitdiffstats
path: root/main/kbd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-07-23 20:01:41 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-07-24 11:43:03 +0000
commit56305e26568b93ae7e57231b52b5dd13fb32fadb (patch)
tree4614de9b159f01754b8769d39c687842072d5dd7 /main/kbd
parent55a13cbbce6592ddada6c88549a2fd0cfe39e770 (diff)
downloadaports-56305e26568b93ae7e57231b52b5dd13fb32fadb.tar.bz2
aports-56305e26568b93ae7e57231b52b5dd13fb32fadb.tar.xz
main/kbd: update filepaths
- Move kbd-misc data form /lib/kbd/ to /usr/share/ - Don't move binaries to /bin - Move setfont to /usr/sbin to override busybox setfont symlink - Include html documentation in kbd-doc package Patch from Bernd Lauert ref #4457
Diffstat (limited to 'main/kbd')
-rw-r--r--main/kbd/APKBUILD35
1 files changed, 19 insertions, 16 deletions
diff --git a/main/kbd/APKBUILD b/main/kbd/APKBUILD
index bd96b7ba42..e4f11c616f 100644
--- a/main/kbd/APKBUILD
+++ b/main/kbd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=kbd
pkgver=2.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="Tools for configuring the console (keyboard, virtual terminals, etc.)"
url="http://ftp.altlinux.org/pub/people/legion/kbd"
arch="all"
@@ -27,7 +27,6 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
-# aclocal -I m4 && automake --add-missing && autoreconf || return 1
# install our error.h
cp "$srcdir"/error.h . || return 1
@@ -56,11 +55,10 @@ build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
- --datadir=/lib/kbd \
- --localedir=/usr/share/locale \
--disable-nls \
- --mandir=/usr/share/man \
+ --prefix=/usr \
+ --datadir=/usr/share \
+ --htmldir=/usr/share/html/$pkgname \
|| return 1
make || return 1
}
@@ -71,20 +69,22 @@ package() {
rm -f "$pkgdir"/usr/lib/*.la
# ro_win.map.gz is useless
- rm -f "$pkgdir"/lib/kbd/keymaps/i386/qwerty/ro_win.map.gz
+ rm -f "$pkgdir"/usr/share/keymaps/i386/qwerty/ro_win.map.gz
# Create additional name for Serbian latin keyboard
- ln -s sr-cy.map.gz "$pkgdir"/lib/kbd/keymaps/i386/qwerty/sr-latin.map.gz
+ ln -s sr-cy.map.gz "$pkgdir"/usr/share/keymaps/i386/qwerty/sr-latin.map.gz
# The rhpl keyboard layout table is indexed by kbd layout names,
# so we need a Korean keyboard
- ln -s us.map.gz "$pkgdir"/lib/kbd/keymaps/i386/qwerty/ko.map.gz
+ ln -s us.map.gz "$pkgdir"/usr/share/keymaps/i386/qwerty/ko.map.gz
- # Move binaries which we use before /usr is mounted to /bin.
- mkdir -p "$pkgdir"/bin
- for binary in setfont dumpkeys kbd_mode unicode_start unicode_stop loadkeys ; do
- mv "$pkgdir"/usr/bin/$binary "$pkgdir"/bin/ || return 1
- done
+ # Install html documentation
+ mkdir -p "$pkgdir"/usr/share/html/$pkgname
+ mv docs/doc/*.html "$pkgdir"/usr/share/html/$pkgname/ || return 1
+
+ # Replace busybox setfont utility.
+ mkdir -p "$pkgdir"/usr/sbin
+ mv "$pkgdir"/usr/bin/setfont "$pkgdir"/usr/sbin/ || return 1
# Link open to openvt
ln -s openvt "$pkgdir"/usr/bin/open
@@ -94,8 +94,11 @@ misc() {
pkgdesc="Data for kbd package"
arch="noarch"
depends=
- mkdir -p "$subpkgdir"/lib
- mv "$pkgdir"/lib/kbd "$subpkgdir"/lib/
+
+ mkdir -p "$subpkgdir"/usr/share/
+ for dir in consolefonts consoletrans keymaps unimaps; do
+ mv "$pkgdir"/usr/share/${dir} "$subpkgdir"/usr/share/ || return 1
+ done
}
md5sums="f1f75f0dd5f7dde89ce47585274366f8 kbd-2.0.2.tar.gz