aboutsummaryrefslogtreecommitdiffstats
path: root/main/kbd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-06-17 12:04:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-06-17 12:04:16 +0000
commit93cbd0a2fc0c977b017af593bb72dcff8a5fd219 (patch)
tree81980c36e158f772b06417ab331eec6b29f8cd78 /main/kbd
parent1bacaa5e99b6a8b5fece18afc6c92c09e6b1b3be (diff)
downloadaports-93cbd0a2fc0c977b017af593bb72dcff8a5fd219.tar.bz2
aports-93cbd0a2fc0c977b017af593bb72dcff8a5fd219.tar.xz
main/kbd: move keymaps to /lib/kbd
Diffstat (limited to 'main/kbd')
-rw-r--r--main/kbd/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/main/kbd/APKBUILD b/main/kbd/APKBUILD
index 4ca11648ef..8eb134f129 100644
--- a/main/kbd/APKBUILD
+++ b/main/kbd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=kbd
pkgver=2.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Tools for configuring the console (keyboard, virtual terminals, etc.)"
url="http://ftp.altlinux.org/pub/people/legion/kbd"
arch="all"
@@ -42,6 +42,7 @@ prepare() {
mv qwerty/cz.map qwerty/cz-qwerty.map
}
+_datadir=/lib/kbd
build() {
cd "$_builddir"
./configure \
@@ -49,7 +50,7 @@ build() {
--host=$CHOST \
--disable-nls \
--prefix=/usr \
- --datadir=/usr/share \
+ --datadir=$_datadir \
--htmldir=/usr/share/html/$pkgname \
|| return 1
make || return 1
@@ -60,14 +61,14 @@ package() {
make DESTDIR="$pkgdir" install || return 1
# ro_win.map.gz is useless
- rm -f "$pkgdir"/usr/share/keymaps/i386/qwerty/ro_win.map.gz
+ rm -f "$pkgdir"${_datadir}/keymaps/i386/qwerty/ro_win.map.gz
# Create additional name for Serbian latin keyboard
- ln -s sr-cy.map.gz "$pkgdir"/usr/share/keymaps/i386/qwerty/sr-latin.map.gz
+ ln -s sr-cy.map.gz "$pkgdir"$_datadir/keymaps/i386/qwerty/sr-latin.map.gz
# The rhpl keyboard layout table is indexed by kbd layout names,
# so we need a Korean keyboard
- ln -s us.map.gz "$pkgdir"/usr/share/keymaps/i386/qwerty/ko.map.gz
+ ln -s us.map.gz "$pkgdir"${_datadir}/keymaps/i386/qwerty/ko.map.gz
# Install html documentation
mkdir -p "$pkgdir"/usr/share/html/$pkgname
@@ -98,9 +99,10 @@ misc() {
arch="noarch"
depends=
- mkdir -p "$subpkgdir"/usr/share/
+ mkdir -p "$subpkgdir"$_datadir
for dir in consolefonts consoletrans keymaps unimaps; do
- mv "$pkgdir"/usr/share/${dir} "$subpkgdir"/usr/share/ || return 1
+ mv "$pkgdir"$_datadir/${dir} "$subpkgdir"/$_datadir/ \
+ || return 1
done
}