aboutsummaryrefslogtreecommitdiffstats
path: root/main/kmod
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-01 19:49:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-01 19:49:56 +0000
commit7d4bf0305089366a46998e42f87f2b09f4bc7f54 (patch)
treeb1a6ceeb6d2dc1a797cc4c6895207d0f26d7938e /main/kmod
parent108fc302bf8a38f49a50a8c8080be5e8beb5c6bf (diff)
downloadaports-7d4bf0305089366a46998e42f87f2b09f4bc7f54.tar.bz2
aports-7d4bf0305089366a46998e42f87f2b09f4bc7f54.tar.xz
main/kmod: moved from testing
Diffstat (limited to 'main/kmod')
-rw-r--r--main/kmod/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/main/kmod/APKBUILD b/main/kmod/APKBUILD
new file mode 100644
index 0000000000..c34e339c30
--- /dev/null
+++ b/main/kmod/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=kmod
+pkgver=4
+pkgrel=0
+pkgdesc="Linux kernel module management utilities"
+url="http://git.profusion.mobi/cgit.cgi/kmod.git/"
+arch="all"
+license="GPLv2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev zlib-dev xz-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://packages.profusion.mobi/kmod/kmod-$pkgver.tar.xz"
+
+_builddir="$srcdir"/kmod-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --bindir=/bin \
+ --with-rootprefix= \
+ --with-rootlibdir=/lib \
+ --with-zlib \
+ --with-xz \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+libs() {
+ pkgdesc="Libraries to handle kernel module loading and unloading"
+ mkdir -p "$subpkgdir"/
+ mv "$pkgdir"/lib "$subpkgdir"/
+}
+
+md5sums="e14450a066a48accd0af1995b3c0232d kmod-4.tar.xz"